reSIProcate
SIP stack, Dialog Usage Manager and related libraries
Loading...
Searching...
No Matches
resip::Mime Member List

This is the complete list of members for resip::Mime, including all inherited members.

addParameter(Parameter *param)resip::ParserCategoryprotected
addParameter(UnknownParameter *unknownParam)resip::ParserCategoryprotected
checkParsed() constresip::LazyParserinline
checkParsed()resip::LazyParserinline
clearUnknownParameters()resip::ParserCategory
clone() constresip::Mimevirtual
clone(void *location) constresip::Mimevirtual
clone(PoolBase *pool) constresip::Mimevirtual
commaHandlingresip::Mimestatic
CommaHandlingMode enum nameresip::ParserCategory
CommasAllowedOutputCommas enum valueresip::ParserCategory
CommasAllowedOutputMulti enum valueresip::ParserCategory
commutativeParameterHash() constresip::ParserCategory
createParam(ParameterTypes::Type type, ParseBuffer &pb, const std::bitset< 256 > &terminators, PoolBase *pool)resip::Mimevirtual
defineParam(accessType, "access-type", DataParameter, "RFC 2046")resip::Mime
defineParam(boundary, "boundary", DataParameter, "RFC 2046")resip::Mime
defineParam(charset, "charset", DataParameter, "RFC 2045")resip::Mime
defineParam(directory, "directory", DataParameter, "RFC 2046")resip::Mime
defineParam(expiration, "expiration", QuotedDataParameter, "RFC 2046")resip::Mime
defineParam(micalg, "micalg", DataParameter, "RFC 1847")resip::Mime
defineParam(mode, "mode", DataParameter, "RFC 2046")resip::Mime
defineParam(name, "name", DataParameter, "RFC 2046")resip::Mime
defineParam(permission, "permission", DataParameter, "RFC 2046")resip::Mime
defineParam(protocol, "protocol", QuotedDataParameter, "RFC 1847")resip::Mime
defineParam(q, "q", QValueParameter, "RFC 3261")resip::Mime
defineParam(server, "server", DataParameter, "RFC 2046")resip::Mime
defineParam(site, "site", DataParameter, "RFC 2046")resip::Mime
defineParam(size, "size", DataParameter, "RFC 2046")resip::Mime
defineParam(smimeType, "smime-type", DataParameter, "RFC 2633")resip::Mime
defineParam(url, "url", QuotedDataParameter, "RFC 4483")resip::Mime
doParse() constresip::LazyParser
EmptyParameterTypeSetresip::ParserCategorystatic
encode(EncodeStream &str) constresip::LazyParser
encodeParameters(EncodeStream &str) constresip::ParserCategory
encodeParsed(EncodeStream &str) constresip::Mimevirtual
errorContext() constresip::ParserCategoryprotectedvirtual
exists(const Param< Mime > &paramType) constresip::Mime
exists(const ParamBase &paramType) constresip::Mimeinline
exists(const ExtensionParameter &param) constresip::Mime
freeParameter(Parameter *p)resip::ParserCategoryinlineprotected
getHeaderField()resip::LazyParserinline
getParameterByData(const Data &data) constresip::ParserCategoryprotected
getParameterByEnum(ParameterTypes::Type type) constresip::ParserCategory
getPool()resip::ParserCategoryinlineprotected
isEqual(const Mime &rhs) constresip::Mime
isParsed() constresip::LazyParserinline
isWellFormed() constresip::LazyParser
LazyParser(const HeaderFieldValue &headerFieldValue)resip::LazyParserexplicit
LazyParser(const char *buf, int length)resip::LazyParser
LazyParser(const HeaderFieldValue &headerFieldValue, HeaderFieldValue::CopyPaddingEnum e)resip::LazyParser
LazyParser(const LazyParser &rhs)resip::LazyParser
LazyParser(const LazyParser &rhs, HeaderFieldValue::CopyPaddingEnum e)resip::LazyParser
LazyParser()resip::LazyParserprotected
markDirty() constresip::LazyParserinline
mHeaderTyperesip::ParserCategoryprotected
Mime()resip::Mime
Mime(const Data &type, const Data &subType)resip::Mime
Mime(const HeaderFieldValue &hfv, Headers::Type type, PoolBase *pool=0)resip::Mime
Mime(const Mime &orig, PoolBase *pool=0)resip::Mime
mParametersresip::ParserCategoryprotected
mPoolresip::ParserCategoryprotected
mUnknownParametersresip::ParserCategoryprotected
NoCommaTokenizing enum valueresip::ParserCategory
numKnownParams() constresip::ParserCategoryinline
numUnknownParams() constresip::ParserCategoryinline
operator!=(const Mime &rhs) constresip::Mime
operator<(const Mime &rhs) constresip::Mime
operator=(const Mime &)resip::Mime
resip::ParserCategory::operator=(const ParserCategory &rhs)resip::ParserCategory
resip::LazyParser::operator=(const LazyParser &rhs)resip::LazyParser
operator==(const Mime &rhs) constresip::Mime
param(const ExtensionParameter &param) constresip::Mime
param(const ExtensionParameter &param)resip::Mime
ParameterList typedefresip::ParserCategoryprotected
ParameterTypeSet typedefresip::ParserCategory
parse(ParseBuffer &pb)resip::Mimevirtual
parseParameters(ParseBuffer &pb)resip::ParserCategory
ParserCategory(const HeaderFieldValue &headerFieldValue, Headers::Type type, PoolBase *pool=0)resip::ParserCategory
ParserCategory(const char *buf, int length, Headers::Type type, PoolBase *pool=0)resip::ParserCategory
ParserCategory(const ParserCategory &rhs, PoolBase *pool=0)resip::ParserCategory
ParserCategory(PoolBase *pool=0)resip::ParserCategoryprotected
remove(const Param< Mime > &paramType)resip::Mime
remove(const ParamBase &paramType)resip::Mime
remove(const ExtensionParameter &param)resip::Mime
removeParameterByData(const Data &data)resip::ParserCategoryprotected
removeParameterByEnum(ParameterTypes::Type type)resip::ParserCategory
removeParametersExcept(const ParameterTypeSet &set=EmptyParameterTypeSet)resip::ParserCategory
setParameter(const Parameter *parameter)resip::ParserCategory
subType() constresip::Mime
subType()resip::Mime
type() constresip::Mime
type()resip::Mime
UnknownParserCategory enum valueresip::ParserCategory
~LazyParser()resip::LazyParservirtual
~ParserCategory()resip::ParserCategoryvirtual