|
reSIProcate
SIP stack, Dialog Usage Manager and related libraries
|
This is the complete list of members for resip::SipMessage, including all inherited members.
| addBuffer(char *buf) | resip::SipMessage | |
| addHeader(Headers::Type header, const char *headerName, uint32_t headerNameLen, const char *value, uint32_t valuelen) | resip::SipMessage | |
| addOutboundDecorator(std::unique_ptr< MessageDecorator > md) | resip::SipMessage | inline |
| brief() const | resip::Message | virtual |
| callOutboundDecorators(const Tuple &src, const Tuple &dest, const Data &sigcompId) | resip::SipMessage | |
| checkContentLength | resip::SipMessage | static |
| clear(bool leaveResponseStuff=false) | resip::SipMessage | protected |
| clearForceTarget() | resip::SipMessage | |
| clearHeaders() | resip::SipMessage | protected |
| clearOutboundDecorators() | resip::SipMessage | |
| clone() const | resip::SipMessage | virtual |
| const_header(const RequestLineType &l) const | resip::SipMessage | inline |
| const_header(const StatusLineType &l) const | resip::SipMessage | inline |
| copyOutboundDecoratorsToStackCancel(SipMessage &cancel) | resip::SipMessage | |
| copyOutboundDecoratorsToStackFailureAck(SipMessage &ack) | resip::SipMessage | |
| defineHeader(ContentDisposition, "Content-Disposition", Token, "RFC 3261") | resip::SipMessage | |
| defineHeader(ContentEncoding, "Content-Encoding", Token, "RFC 3261") | resip::SipMessage | |
| defineHeader(MIMEVersion, "Mime-Version", Token, "RFC 3261") | resip::SipMessage | |
| defineHeader(Priority, "Priority", Token, "RFC 3261") | resip::SipMessage | |
| defineHeader(Event, "Event", Token, "RFC 3265") | resip::SipMessage | |
| defineHeader(SubscriptionState, "Subscription-State", Token, "RFC 3265") | resip::SipMessage | |
| defineHeader(SIPETag, "SIP-ETag", Token, "RFC 3903") | resip::SipMessage | |
| defineHeader(SIPIfMatch, "SIP-If-Match", Token, "RFC 3903") | resip::SipMessage | |
| defineHeader(ContentId, "Content-ID", Token, "RFC 2045") | resip::SipMessage | |
| defineHeader(ReferSub, "Refer-Sub", Token, "RFC 4488") | resip::SipMessage | |
| defineHeader(AnswerMode, "Answer-Mode", Token, "draft-ietf-answermode-04") | resip::SipMessage | |
| defineHeader(PrivAnswerMode, "Priv-Answer-Mode", Token, "draft-ietf-answermode-04") | resip::SipMessage | |
| defineHeader(ContentType, "Content-Type", Mime, "RFC 3261") | resip::SipMessage | |
| defineHeader(IdentityInfo, "Identity-Info", GenericUri, "RFC 4474") | resip::SipMessage | |
| defineHeader(From, "From", NameAddr, "RFC 3261") | resip::SipMessage | |
| defineHeader(To, "To", NameAddr, "RFC 3261") | resip::SipMessage | |
| defineHeader(ReplyTo, "Reply-To", NameAddr, "RFC 3261") | resip::SipMessage | |
| defineHeader(ReferTo, "Refer-To", NameAddr, "RFC 3515") | resip::SipMessage | |
| defineHeader(ReferredBy, "Referred-By", NameAddr, "RFC 3892") | resip::SipMessage | |
| defineHeader(PCalledPartyId, "P-Called-Party-ID", NameAddr, "RFC 3455") | resip::SipMessage | |
| defineHeader(ContentTransferEncoding, "Content-Transfer-Encoding", StringCategory, "RFC 1521") | resip::SipMessage | |
| defineHeader(Organization, "Organization", StringCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(SecWebSocketKey, "Sec-WebSocket-Key", StringCategory, "RFC 6455") | resip::SipMessage | |
| defineHeader(SecWebSocketKey1, "Sec-WebSocket-Key1", StringCategory, "draft-hixie- thewebsocketprotocol-76") | resip::SipMessage | |
| defineHeader(SecWebSocketKey2, "Sec-WebSocket-Key2", StringCategory, "draft-hixie- thewebsocketprotocol-76") | resip::SipMessage | |
| defineHeader(Origin, "Origin", StringCategory, "draft-hixie- thewebsocketprotocol-76") | resip::SipMessage | |
| defineHeader(Host, "Host", StringCategory, "draft-hixie- thewebsocketprotocol-76") | resip::SipMessage | |
| defineHeader(SecWebSocketAccept, "Sec-WebSocket-Accept", StringCategory, "RFC 6455") | resip::SipMessage | |
| defineHeader(Server, "Server", StringCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(Subject, "Subject", StringCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(UserAgent, "User-Agent", StringCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(Timestamp, "Timestamp", StringCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(ContentLength, "Content-Length", UInt32Category, "RFC 3261") | resip::SipMessage | |
| defineHeader(MaxForwards, "Max-Forwards", UInt32Category, "RFC 3261") | resip::SipMessage | |
| defineHeader(MinExpires, "Min-Expires", UInt32Category, "RFC 3261") | resip::SipMessage | |
| defineHeader(RSeq, "RSeq", UInt32Category, "RFC 3261") | resip::SipMessage | |
| defineHeader(RetryAfter, "Retry-After", UInt32Category, "RFC 3261") | resip::SipMessage | |
| defineHeader(FlowTimer, "Flow-Timer", UInt32Category, "RFC 5626") | resip::SipMessage | |
| defineHeader(Expires, "Expires", ExpiresCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(SessionExpires, "Session-Expires", ExpiresCategory, "RFC 4028") | resip::SipMessage | |
| defineHeader(MinSE, "Min-SE", ExpiresCategory, "RFC 4028") | resip::SipMessage | |
| defineHeader(CallID, "Call-ID", CallID, "RFC 3261") | resip::SipMessage | |
| defineHeader(Replaces, "Replaces", CallID, "RFC 3891") | resip::SipMessage | |
| defineHeader(InReplyTo, "In-Reply-To", CallID, "RFC 3261") | resip::SipMessage | |
| defineHeader(Join, "Join", CallId, "RFC 3911") | resip::SipMessage | |
| defineHeader(TargetDialog, "Target-Dialog", CallId, "RFC 4538") | resip::SipMessage | |
| defineHeader(AuthenticationInfo, "Authentication-Info", Auth, "RFC 3261") | resip::SipMessage | |
| defineHeader(CSeq, "CSeq", CSeqCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(Date, "Date", DateCategory, "RFC 3261") | resip::SipMessage | |
| defineHeader(RAck, "RAck", RAckCategory, "RFC 3262") | resip::SipMessage | |
| defineHeader(PChargingVector, "P-Charging-Vector", Token, "RFC 3455") | resip::SipMessage | |
| defineHeader(PChargingFunctionAddresses, "P-Charging-Function-Addresses", Token, "RFC 3455") | resip::SipMessage | |
| defineMultiHeader(AllowEvents, "Allow-Events", Token, "RFC 3265") | resip::SipMessage | |
| defineMultiHeader(Identity, "Identity", IdentityCategory, "RFC 8224") | resip::SipMessage | |
| defineMultiHeader(AcceptEncoding, "Accept-Encoding", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(AcceptLanguage, "Accept-Language", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Allow, "Allow", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(ContentLanguage, "Content-Language", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(ProxyRequire, "Proxy-Require", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Require, "Require", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Supported, "Supported", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Unsupported, "Unsupported", Token, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(SecurityClient, "Security-Client", Token, "RFC 3329") | resip::SipMessage | |
| defineMultiHeader(SecurityServer, "Security-Server", Token, "RFC 3329") | resip::SipMessage | |
| defineMultiHeader(SecurityVerify, "Security-Verify", Token, "RFC 3329") | resip::SipMessage | |
| defineMultiHeader(RequestDisposition, "Request-Disposition", Token, "RFC 3841") | resip::SipMessage | |
| defineMultiHeader(Reason, "Reason", Token, "RFC 3326") | resip::SipMessage | |
| defineMultiHeader(Privacy, "Privacy", PrivacyCategory, "RFC 3323") | resip::SipMessage | |
| defineMultiHeader(PMediaAuthorization, "P-Media-Authorization", Token, "RFC 3313") | resip::SipMessage | |
| defineMultiHeader(Accept, "Accept", Mime, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(CallInfo, "Call-Info", GenericUri, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(AlertInfo, "Alert-Info", GenericUri, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(ErrorInfo, "Error-Info", GenericUri, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(RecordRoute, "Record-Route", NameAddr, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Route, "Route", NameAddr, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Contact, "Contact", NameAddr, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Path, "Path", NameAddr, "RFC 3327") | resip::SipMessage | |
| defineMultiHeader(AcceptContact, "Accept-Contact", NameAddr, "RFC 3841") | resip::SipMessage | |
| defineMultiHeader(RejectContact, "Reject-Contact", NameAddr, "RFC 3841") | resip::SipMessage | |
| defineMultiHeader(PAssertedIdentity, "P-Asserted-Identity", NameAddr, "RFC 3325") | resip::SipMessage | |
| defineMultiHeader(PPreferredIdentity, "P-Preferred-Identity", NameAddr, "RFC 3325") | resip::SipMessage | |
| defineMultiHeader(PAssociatedUri, "P-Associated-URI", NameAddr, "RFC 3455") | resip::SipMessage | |
| defineMultiHeader(ServiceRoute, "Service-Route", NameAddr, "RFC 3608") | resip::SipMessage | |
| defineMultiHeader(RemotePartyId, "Remote-Party-ID", NameAddr, "draft-ietf-sip-privacy-04") | resip::SipMessage | |
| defineMultiHeader(HistoryInfo, "History-Info", NameAddr, "RFC 4244") | resip::SipMessage | |
| defineMultiHeader(Diversion, "Diversion", NameAddr, "RFC 5806") | resip::SipMessage | |
| defineMultiHeader(Cookie, "Cookie", StringCategory, "RFC 6265") | resip::SipMessage | |
| defineMultiHeader(Authorization, "Authorization", Auth, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(ProxyAuthenticate, "Proxy-Authenticate", Auth, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(ProxyAuthorization, "Proxy-Authorization", Auth, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(WWWAuthenticate, "Www-Authenticate", Auth, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Warning, "Warning", WarningCategory, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(Via, "Via", Via, "RFC 3261") | resip::SipMessage | |
| defineMultiHeader(PAccessNetworkInfo, "P-Access-Network-Info", Token, "RFC 7315") | resip::SipMessage | |
| defineMultiHeader(PVisitedNetworkID, "P-Visited-Network-ID", TokenOrQuotedStringCategory, "RFC 3455") | resip::SipMessage | |
| defineMultiHeader(UserToUser, "User-to-User", TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17") | resip::SipMessage | |
| empty(const HeaderBase &headerType) const | resip::SipMessage | |
| encode(EncodeStream &str) const | resip::SipMessage | virtual |
| encodeBrief(EncodeStream &str) const | resip::SipMessage | virtual |
| encodeEmbedded(EncodeStream &str) const | resip::SipMessage | |
| encodeSingleHeader(Headers::Type type, EncodeStream &str) const | resip::SipMessage | |
| encodeSipFrag(EncodeStream &str) const | resip::SipMessage | virtual |
| exists(const HeaderBase &headerType) const | resip::SipMessage | |
| exists(const ExtensionHeader &symbol) const | resip::SipMessage | |
| freeMem(bool leaveResponseStuff=false) | resip::SipMessage | protected |
| getCanonicalIdentityString() const | resip::SipMessage | |
| getConnectionInfo() const noexcept | resip::SipMessage | inline |
| getContents() const | resip::SipMessage | |
| getCreatedTimeMicroSec() const | resip::SipMessage | inline |
| getDestination() | resip::SipMessage | inline |
| getForceTarget() const | resip::SipMessage | |
| getRawBody() const noexcept | resip::SipMessage | inline |
| getRawHeader(Headers::Type headerType) const | resip::SipMessage | |
| getRawHeaders() const noexcept | resip::SipMessage | inline |
| getRawUnknownHeaders() const noexcept | resip::SipMessage | inline |
| getReason() const | resip::SipMessage | inline |
| getReceivedTransportTuple() const | resip::SipMessage | inline |
| getRFC2543TransactionId() const | resip::SipMessage | |
| getSecurityAttributes() const noexcept | resip::SipMessage | inline |
| getSource() const | resip::SipMessage | inline |
| getTlsDomain() const | resip::SipMessage | inline |
| getTlsPeerNames() const | resip::SipMessage | |
| getTlsSni() const | resip::SipMessage | |
| getTransactionId() const | resip::SipMessage | virtual |
| getTransactionUser() | resip::Message | inlineprotected |
| getWsCookieContext() const noexcept | resip::SipMessage | |
| getWsCookies() const | resip::SipMessage | |
| hasForceTarget() const | resip::SipMessage | |
| hasTransactionUser() const | resip::Message | inlineprotected |
| header(const RequestLineType &l) const | resip::SipMessage | |
| header(const RequestLineType &l) | resip::SipMessage | |
| header(const StatusLineType &l) const | resip::SipMessage | |
| header(const StatusLineType &l) | resip::SipMessage | |
| header(const ExtensionHeader &symbol) const | resip::SipMessage | |
| header(const ExtensionHeader &symbol) | resip::SipMessage | |
| init(const SipMessage &rhs) | resip::SipMessage | protected |
| isClientTransaction() const | resip::SipMessage | virtual |
| isExternal() const | resip::SipMessage | inline |
| isFromWire() const | resip::SipMessage | inline |
| isInvalid() const | resip::SipMessage | inline |
| isRequest() const | resip::SipMessage | inline |
| isResponse() const | resip::SipMessage | inline |
| make(const Data &buffer, bool isExternal=false) | resip::SipMessage | static |
| mergeUri(const Uri &source) | resip::SipMessage | |
| Message() | resip::Message | |
| method() const | resip::SipMessage | |
| methodStr() const | resip::SipMessage | |
| mIsBadAck200 | resip::SipMessage | |
| mIsDecorated | resip::SipMessage | |
| mTu | resip::Message | protected |
| operator=(const SipMessage &rhs) | resip::SipMessage | |
| parseAllHeaders() | resip::SipMessage | |
| releaseContents() | resip::SipMessage | |
| remove(const HeaderBase &headerType) | resip::SipMessage | inline |
| remove(Headers::Type type) | resip::SipMessage | |
| remove(const ExtensionHeader &symbol) | resip::SipMessage | |
| RESIP_HeapCount(SipMessage) | resip::SipMessage | |
| resip::TransactionMessage::RESIP_HeapCount(TransactionMessage) | resip::TransactionMessage | |
| rollbackOutboundDecorators() | resip::SipMessage | |
| setBody(const char *start, uint32_t len) | resip::SipMessage | |
| setConnectionInfo(std::shared_ptr< const ConnectionInfo > connectionInfo) noexcept | resip::SipMessage | inline |
| setContents(const Contents *contents) | resip::SipMessage | |
| setContents(std::unique_ptr< Contents > contents) | resip::SipMessage | |
| setDestination(const Tuple &tuple) | resip::SipMessage | inline |
| setForceTarget(const Uri &uri) | resip::SipMessage | |
| setFromExternal() | resip::SipMessage | inline |
| setFromTU() | resip::SipMessage | inline |
| setRawBody(const HeaderFieldValue &body) | resip::SipMessage | |
| setRawHeader(const HeaderFieldValueList *hfvs, Headers::Type headerType) | resip::SipMessage | |
| setReceivedTransportTuple(const Tuple &transportTuple) | resip::SipMessage | inline |
| setRFC2543TransactionId(const Data &tid) | resip::SipMessage | |
| setSecurityAttributes(std::unique_ptr< SecurityAttributes >) noexcept | resip::SipMessage | |
| setSource(const Tuple &tuple) | resip::SipMessage | inline |
| setStartLine(const char *start, uint32_t len) | resip::SipMessage | |
| setTlsDomain(const Data &domain) | resip::SipMessage | inline |
| setTlsPeerNames(const std::list< Data > &tlsPeerNames) | resip::SipMessage | |
| setTransactionUser(TransactionUser *t) | resip::Message | inlineprotected |
| setWsCookieContext(std::shared_ptr< WsCookieContext > wsCookieContext) | resip::SipMessage | |
| setWsCookies(const CookieList &wsCookies) | resip::SipMessage | |
| SipMessage(const Tuple *receivedTransport=0) | resip::SipMessage | explicit |
| SipMessage(const SipMessage &message) | resip::SipMessage | |
| TransportSelector | resip::SipMessage | friend |
| UnknownHeaders typedef | resip::SipMessage | |
| ~Message() | resip::Message | inlinevirtual |
| ~SipMessage() | resip::SipMessage | virtual |