| addParameter(Parameter *param) | resip::ParserCategory | protected |
| addParameter(UnknownParameter *unknownParam) | resip::ParserCategory | protected |
| checkParsed() const | resip::LazyParser | inline |
| checkParsed() | resip::LazyParser | inline |
| clearUnknownParameters() | resip::ParserCategory | |
| clone() const | resip::Via | virtual |
| clone(void *location) const | resip::Via | virtual |
| clone(PoolBase *pool) const | resip::Via | virtual |
| commaHandling | resip::Via | static |
| CommaHandlingMode enum name | resip::ParserCategory | |
| CommasAllowedOutputCommas enum value | resip::ParserCategory | |
| CommasAllowedOutputMulti enum value | resip::ParserCategory | |
| commutativeParameterHash() const | resip::ParserCategory | |
| createParam(ParameterTypes::Type type, ParseBuffer &pb, const std::bitset< 256 > &terminators, PoolBase *pool) | resip::Via | virtual |
| defineParam(branch, "branch", BranchParameter, "RFC 3261") | resip::Via | |
| defineParam(comp, "comp", DataParameter, "RFC 3486") | resip::Via | |
| defineParam(received, "received", ReceivedParameter, "RFC 3261") | resip::Via | |
| defineParam(rport, "rport", RportParameter, "RFC 3581") | resip::Via | |
| defineParam(ttl, "ttl", UInt32Parameter, "RFC 3261") | resip::Via | |
| defineParam(sigcompId, "sigcomp-id", QuotedDataParameter, "RFC 5049") | resip::Via | |
| defineParam(maddr, "maddr", DataParameter, "RFC 3261") | resip::Via | |
| doParse() const | resip::LazyParser | |
| EmptyParameterTypeSet | resip::ParserCategory | static |
| encode(EncodeStream &str) const | resip::LazyParser | |
| encodeParameters(EncodeStream &str) const | resip::ParserCategory | |
| encodeParsed(EncodeStream &str) const | resip::Via | virtual |
| errorContext() const | resip::ParserCategory | protectedvirtual |
| exists(const Param< Via > ¶mType) const | resip::Via | |
| exists(const ParamBase ¶mType) const | resip::Via | inline |
| exists(const ExtensionParameter ¶m) const | resip::Via | |
| freeParameter(Parameter *p) | resip::ParserCategory | inlineprotected |
| getHeaderField() | resip::LazyParser | inline |
| getParameterByData(const Data &data) const | resip::ParserCategory | protected |
| getParameterByEnum(ParameterTypes::Type type) const | resip::ParserCategory | |
| getPool() | resip::ParserCategory | inlineprotected |
| isParsed() const | resip::LazyParser | inline |
| isWellFormed() const | resip::LazyParser | |
| LazyParser(const HeaderFieldValue &headerFieldValue) | resip::LazyParser | explicit |
| LazyParser(const char *buf, int length) | resip::LazyParser | |
| LazyParser(const HeaderFieldValue &headerFieldValue, HeaderFieldValue::CopyPaddingEnum e) | resip::LazyParser | |
| LazyParser(const LazyParser &rhs) | resip::LazyParser | |
| LazyParser(const LazyParser &rhs, HeaderFieldValue::CopyPaddingEnum e) | resip::LazyParser | |
| LazyParser() | resip::LazyParser | protected |
| markDirty() const | resip::LazyParser | inline |
| mHeaderType | resip::ParserCategory | protected |
| mParameters | resip::ParserCategory | protected |
| mPool | resip::ParserCategory | protected |
| mUnknownParameters | resip::ParserCategory | protected |
| NoCommaTokenizing enum value | resip::ParserCategory | |
| numKnownParams() const | resip::ParserCategory | inline |
| numUnknownParams() const | resip::ParserCategory | inline |
| operator=(const Via &) | resip::Via | |
| resip::ParserCategory::operator=(const ParserCategory &rhs) | resip::ParserCategory | |
| resip::LazyParser::operator=(const LazyParser &rhs) | resip::LazyParser | |
| param(const ExtensionParameter ¶m) const | resip::Via | |
| param(const ExtensionParameter ¶m) | resip::Via | |
| ParameterList typedef | resip::ParserCategory | protected |
| ParameterTypeSet typedef | resip::ParserCategory | |
| parse(ParseBuffer &pb) | resip::Via | virtual |
| parseParameters(ParseBuffer &pb) | resip::ParserCategory | |
| ParserCategory(const HeaderFieldValue &headerFieldValue, Headers::Type type, PoolBase *pool=0) | resip::ParserCategory | |
| ParserCategory(const char *buf, int length, Headers::Type type, PoolBase *pool=0) | resip::ParserCategory | |
| ParserCategory(const ParserCategory &rhs, PoolBase *pool=0) | resip::ParserCategory | |
| ParserCategory(PoolBase *pool=0) | resip::ParserCategory | protected |
| protocolName() | resip::Via | |
| protocolName() const | resip::Via | |
| protocolVersion() | resip::Via | |
| protocolVersion() const | resip::Via | |
| remove(const Param< Via > ¶mType) | resip::Via | |
| remove(const ParamBase ¶mType) | resip::Via | |
| remove(const ExtensionParameter ¶m) | resip::Via | |
| removeParameterByData(const Data &data) | resip::ParserCategory | protected |
| removeParameterByEnum(ParameterTypes::Type type) | resip::ParserCategory | |
| removeParametersExcept(const ParameterTypeSet &set=EmptyParameterTypeSet) | resip::ParserCategory | |
| sentHost() | resip::Via | |
| sentHost() const | resip::Via | |
| sentPort() | resip::Via | |
| sentPort() const | resip::Via | |
| setParameter(const Parameter *parameter) | resip::ParserCategory | |
| transport() | resip::Via | |
| transport() const | resip::Via | |
| UnknownParserCategory enum value | resip::ParserCategory | |
| Via() | resip::Via | |
| Via(const HeaderFieldValue &hfv, Headers::Type type, PoolBase *pool=0) | resip::Via | |
| Via(const Via &orig, PoolBase *pool=0) | resip::Via | |
| ~LazyParser() | resip::LazyParser | virtual |
| ~ParserCategory() | resip::ParserCategory | virtual |