|
| | Via () |
| |
| | Via (const HeaderFieldValue &hfv, Headers::Type type, PoolBase *pool=0) |
| |
| | Via (const Via &orig, PoolBase *pool=0) |
| |
| Via & | operator= (const Via &) |
| |
| Data & | protocolName () |
| |
| const Data & | protocolName () const |
| |
| Data & | protocolVersion () |
| |
| const Data & | protocolVersion () const |
| |
| Data & | transport () |
| |
| const Data & | transport () const |
| |
| Data & | sentHost () |
| |
| const Data & | sentHost () const |
| |
| int & | sentPort () |
| |
| int | sentPort () const |
| |
| virtual void | parse (ParseBuffer &pb) |
| |
| virtual ParserCategory * | clone () const |
| |
| virtual ParserCategory * | clone (void *location) const |
| |
| virtual ParserCategory * | clone (PoolBase *pool) const |
| |
| virtual EncodeStream & | encodeParsed (EncodeStream &str) const |
| |
| virtual Parameter * | createParam (ParameterTypes::Type type, ParseBuffer &pb, const std::bitset< 256 > &terminators, PoolBase *pool) |
| |
| bool | exists (const Param< Via > ¶mType) const |
| |
| void | remove (const Param< Via > ¶mType) |
| |
| | defineParam (branch, "branch", BranchParameter, "RFC 3261") |
| |
| | defineParam (comp, "comp", DataParameter, "RFC 3486") |
| |
| | defineParam (received, "received", ReceivedParameter, "RFC 3261") |
| |
| | defineParam (rport, "rport", RportParameter, "RFC 3581") |
| |
| | defineParam (ttl, "ttl", UInt32Parameter, "RFC 3261") |
| |
| | defineParam (sigcompId, "sigcomp-id", QuotedDataParameter, "RFC 5049") |
| |
| | defineParam (maddr, "maddr", DataParameter, "RFC 3261") |
| |
| bool | exists (const ParamBase ¶mType) const |
| | Checks for the existence of a natively supported parameter.
|
| |
| bool | exists (const ExtensionParameter ¶m) const |
| | Checks for the existence of a non-natively-supported parameter.
|
| |
| void | remove (const ParamBase ¶mType) |
| | Removes a natively supported parameter, if the parameter is present.
|
| |
| void | remove (const ExtensionParameter ¶m) |
| | Removes a non-natively-supported parameter, if the parameter is present.
|
| |
| const Data & | param (const ExtensionParameter ¶m) const |
| | Const accessor for non-natively-supported parameter types.
|
| |
| Data & | param (const ExtensionParameter ¶m) |
| | Accessor for non-natively-supported parameter types.
|
| |
| | ParserCategory (const HeaderFieldValue &headerFieldValue, Headers::Type type, PoolBase *pool=0) |
| |
| | ParserCategory (const char *buf, int length, Headers::Type type, PoolBase *pool=0) |
| |
| | ParserCategory (const ParserCategory &rhs, PoolBase *pool=0) |
| |
| ParserCategory & | operator= (const ParserCategory &rhs) |
| |
| virtual | ~ParserCategory () |
| |
| bool | exists (const ParamBase ¶mType) const |
| | Checks for the existence of a natively supported parameter.
|
| |
| void | remove (const ParamBase ¶mType) |
| | Removes a natively supported parameter, if the parameter is present.
|
| |
| const Data & | param (const ExtensionParameter ¶m) const |
| | Const accessor for non-natively-supported parameter types.
|
| |
| Data & | param (const ExtensionParameter ¶m) |
| | Accessor for non-natively-supported parameter types.
|
| |
| void | remove (const ExtensionParameter ¶m) |
| | Removes a non-natively-supported parameter, if the parameter is present.
|
| |
| bool | exists (const ExtensionParameter ¶m) const |
| | Checks for the existence of a non-natively-supported parameter.
|
| |
| void | removeParametersExcept (const ParameterTypeSet &set=EmptyParameterTypeSet) |
| | Removes all known parameters except those that are specified in set.
|
| |
| void | clearUnknownParameters () |
| |
| void | parseParameters (ParseBuffer &pb) |
| |
| EncodeStream & | encodeParameters (EncodeStream &str) const |
| | Encodes parameters as they should appear on the wire.
|
| |
| Data | commutativeParameterHash () const |
| |
| Parameter * | getParameterByEnum (ParameterTypes::Type type) const |
| |
| void | removeParameterByEnum (ParameterTypes::Type type) |
| |
| void | setParameter (const Parameter *parameter) |
| |
| int | numKnownParams () const |
| | Returns the number of known (natively supported) parameters.
|
| |
| int | numUnknownParams () const |
| | Returns the number of unknown parameters.
|
| |
| | LazyParser (const HeaderFieldValue &headerFieldValue) |
| |
| | LazyParser (const char *buf, int length) |
| |
| | LazyParser (const HeaderFieldValue &headerFieldValue, HeaderFieldValue::CopyPaddingEnum e) |
| |
| | LazyParser (const LazyParser &rhs) |
| |
| | LazyParser (const LazyParser &rhs, HeaderFieldValue::CopyPaddingEnum e) |
| |
| LazyParser & | operator= (const LazyParser &rhs) |
| |
| virtual | ~LazyParser () |
| |
| EncodeStream & | encode (EncodeStream &str) const |
| | Encodes this element to a stream, in the fashion it should be represented on the wire.
|
| |
| bool | isParsed () const |
| | Returns true iff a parse has been attempted.
|
| |
| HeaderFieldValue & | getHeaderField () |
| |
| void | checkParsed () const |
| |
| void | checkParsed () |
| |
| void | doParse () const |
| |
| void | markDirty () const |
| |
| bool | isWellFormed () const |
| | Returns true iff this element was parsed successfully, according to the implementation of parse().
|
| |
Represents the "via-parm" element in the RFC 3261 grammar.
Definition at line 17 of file Via.hxx.