reSIProcate
SIP stack, Dialog Usage Manager and related libraries
Loading...
Searching...
No Matches
SIP Grammar Elements

Classes

class  resip::Auth
 Represents the "credentials" and "challenge" elements in the SIP grammar. More...
 
class  resip::BranchParameter
 Represents the "via-branch" parameter of the RFC 3261 grammar. More...
 
class  resip::CallID
 Represents the "callid" element in the SIP grammar. More...
 
class  resip::CSeqCategory
 Represents a CSeq header field value (this doesn't have an official name in the RFC 3261 grammar). More...
 
class  resip::DataParameter
 Generically represents miscellaneous parameter data. More...
 
class  resip::DateCategory
 Represents the "SIP-date" element in the RFC 3261 grammar. More...
 
class  resip::ExistsParameter
 Represents various parameters that are indicated to be in effect merely by being present, e.g. More...
 
class  resip::ExpiresCategory
 Represents the header field value for an Expires-type header. More...
 
class  resip::FloatParameter
 Generically represents floating point values conveyed by SIP parameters. More...
 
class  resip::GenericUri
 Represents the "absoluteURI" element in the RFC 3261 grammar. More...
 
class  resip::IdentityCategory
 Represents an Identity header from RFC8824. More...
 
class  resip::IntegerParameter
 Generically represents integer values conveyed by SIP parameters. More...
 
class  resip::Mime
 Represents the "media-type" element in the RFC 3261 grammar. More...
 
class  resip::NameAddr
 Represents the "name-addr" and the "addr-spec" elements in the RFC 3261 grammar. More...
 
class  resip::PrivacyCategory
 Represents the "token" element in the RFC 3261 grammar. More...
 
class  resip::QuotedDataParameter
 Generically represents miscellaneous parameter data that is encoded using double quotes. More...
 
class  resip::QValueParameter
 Represents the "q" parameter value of the RFC 3261 grammar. More...
 
class  resip::RAckCategory
 Represents the RAck header field value defined in the RFC 3262 grammar. More...
 
class  resip::ReceivedParameter
 Represents the "via-received" element in the RFC 3261 grammar. More...
 
class  resip::RequestLine
 Represents the "Request-Line" element in the RFC 3261 grammar. More...
 
class  resip::RportParameter
 Represents the "response-port" element of the SIP grammar (as extended in RFC 3581). More...
 
class  resip::StatusLine
 Represents the "Status-Line" element in the RFC 3261 grammar. More...
 
class  resip::StringCategory
 Represents the "header-value" element in the RFC 3261 grammar (ie, an unknown header field value). More...
 
class  resip::Token
 Represents the "token" element in the RFC 3261 grammar. More...
 
class  resip::TokenOrQuotedStringCategory
 Generically represents a token whose value can be wrapped and encoded using double quotes. More...
 
class  resip::UInt32Category
 Represents a numeric-with-comment header field value. More...
 
class  resip::UInt32Parameter
 Generically represents unsigned 32-bit integer values conveyed by SIP parameters. More...
 
class  resip::UnknownParameter
 Generically used to represent any parameter that is not known by the implmentation. More...
 
class  resip::Uri
 Represents the "SIP-URI" and "SIPS-URI" elements in the RFC 3261 grammar. More...
 
class  resip::UriParameter
 Represents a URI enclosed in angle brackets, used in Identity headers for RFC8224. More...
 
class  resip::Via
 Represents the "via-parm" element in the RFC 3261 grammar. More...
 
class  resip::WarningCategory
 Represents the "warning-value" element in the RFC 3261 grammar. More...
 
class  resip::ParameterTypes
 This is one of the places where new parameter types must be defined. More...
 

Detailed Description