reSIProcate
SIP stack, Dialog Usage Manager and related libraries
Loading...
Searching...
No Matches
Mime.cxx File Reference
#include "resip/stack/Mime.hxx"
#include "rutil/Data.hxx"
#include "rutil/DnsUtil.hxx"
#include "rutil/Logger.hxx"
#include "rutil/ParseBuffer.hxx"

Go to the source code of this file.

Macros

#define RESIPROCATE_SUBSYSTEM   Subsystem::SIP
 
#define defineParam(_enum, _name, _type, _RFC_ref_ignored)
 

Functions

 defineParam (accessType, "access-type", DataParameter, "RFC 2046")
 
 defineParam (boundary, "boundary", DataParameter, "RFC 2046")
 
 defineParam (charset, "charset", DataParameter, "RFC 2045")
 
 defineParam (directory, "directory", DataParameter, "RFC 2046")
 
 defineParam (expiration, "expiration", QuotedDataParameter, "RFC 2046")
 
 defineParam (micalg, "micalg", DataParameter, "RFC 1847")
 
 defineParam (mode, "mode", DataParameter, "RFC 2046")
 
 defineParam (name, "name", DataParameter, "RFC 2046")
 
 defineParam (permission, "permission", DataParameter, "RFC 2046")
 
 defineParam (protocol, "protocol", QuotedDataParameter, "RFC 1847")
 
 defineParam (q, "q", QValueParameter, "RFC 3261")
 
 defineParam (server, "server", DataParameter, "RFC 2046")
 
 defineParam (site, "site", DataParameter, "RFC 2046")
 
 defineParam (size, "size", DataParameter, "RFC 2046")
 
 defineParam (smimeType, "smime-type", DataParameter, "RFC 2633")
 
 defineParam (url, "url", QuotedDataParameter, "RFC 4483")
 
 HashValueImp (resip::Mime, data.type().caseInsensitiveTokenHash() ^ data.subType().caseInsensitiveTokenHash())
 

Macro Definition Documentation

◆ defineParam

#define defineParam (   _enum,
  _name,
  _type,
  _RFC_ref_ignored 
)
Value:
_enum##_Param::DType& \
Mime::param(const _enum##_Param& paramType) \
{ \
checkParsed(); \
_enum##_Param::Type* p = \
static_cast<_enum##_Param::Type*>(getParameterByEnum(paramType.getTypeNum())); \
if (!p) \
{ \
p = new _enum##_Param::Type(paramType.getTypeNum()); \
mParameters.push_back(p); \
} \
return p->value(); \
} \
\
const _enum##_Param::DType& \
Mime::param(const _enum##_Param& paramType) const \
{ \
checkParsed(); \
_enum##_Param::Type* p = \
static_cast<_enum##_Param::Type*>(getParameterByEnum(paramType.getTypeNum())); \
if (!p) \
{ \
InfoLog(<< "Missing parameter " _name " " << ParameterTypes::ParameterNames[paramType.getTypeNum()]); \
DebugLog(<< *this); \
throw Exception("Missing parameter " _name, __FILE__, __LINE__); \
} \
return p->value(); \
}
static Data ParameterNames[MAX_PARAMETER]
static array of ParameterNames indexed by the 2nd element in defineParam(...)

Definition at line 192 of file Mime.cxx.

◆ RESIPROCATE_SUBSYSTEM

#define RESIPROCATE_SUBSYSTEM   Subsystem::SIP

Definition at line 15 of file Mime.cxx.

Function Documentation

◆ defineParam() [1/16]

defineParam ( accessType  ,
"access-type"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [2/16]

defineParam ( boundary  ,
"boundary"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [3/16]

defineParam ( charset  ,
"charset"  ,
DataParameter  ,
"RFC 2045"   
)

◆ defineParam() [4/16]

defineParam ( directory  ,
"directory"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [5/16]

defineParam ( expiration  ,
"expiration"  ,
QuotedDataParameter  ,
"RFC 2046"   
)

◆ defineParam() [6/16]

defineParam ( micalg  ,
"micalg"  ,
DataParameter  ,
"RFC 1847"   
)

◆ defineParam() [7/16]

defineParam ( mode  ,
"mode"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [8/16]

defineParam ( name  ,
"name"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [9/16]

defineParam ( permission  ,
"permission"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [10/16]

defineParam ( protocol  ,
"protocol"  ,
QuotedDataParameter  ,
"RFC 1847"   
)

◆ defineParam() [11/16]

defineParam ( q  ,
"q"  ,
QValueParameter  ,
"RFC 3261"   
)

◆ defineParam() [12/16]

defineParam ( server  ,
"server"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [13/16]

defineParam ( site  ,
"site"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [14/16]

defineParam ( size  ,
"size"  ,
DataParameter  ,
"RFC 2046"   
)

◆ defineParam() [15/16]

defineParam ( smimeType  ,
"smime-type"  ,
DataParameter  ,
"RFC 2633"   
)

◆ defineParam() [16/16]

defineParam ( url  ,
"url"  ,
QuotedDataParameter  ,
"RFC 4483"   
)

◆ HashValueImp()

HashValueImp ( resip::Mime  ,
data.  type).caseInsensitiveTokenHash() ^ data.subType().caseInsensitiveTokenHash( 
)