1#if !defined(RESIP_PARAMETERTYPEENUMS_HXX)
2#define RESIP_PARAMETERTYPEENUMS_HXX
13#define defineParam(_enum, _name, _type, _rfc) _enum
18#define UNUSED_defineParam(_enum, _name, _type, _rfc) SAVE##_enum, _enum = UNKNOWN, RESET##enum = SAVE##_enum-1
184 static Type getType(
const char* start,
size_t length);
211#undef UNUSED_defineParam
Represents the "via-branch" parameter of the RFC 3261 grammar.
Generically represents miscellaneous parameter data.
An alternative to std::string, encapsulates an arbitrary buffer of bytes.
Represents various parameters that are indicated to be in effect merely by being present,...
This is one of the places where new parameter types must be defined.
Parameter *(* Factory)(ParameterTypes::Type, ParseBuffer &, const std::bitset< 256 > &terminators, PoolBase *pool)
static Type getType(const char *start, size_t length)
does a convert to enum from a pointer into the HFV raw buffer
static Factory ParameterFactories[MAX_PARAMETER]
static array of Factorys indexed by the 2nd element in defineParam(...)
static Data ParameterNames[MAX_PARAMETER]
static array of ParameterNames indexed by the 2nd element in defineParam(...)
Provides string-parsing functionality with protection from buffer overflow.
Represents the "q" parameter value of the RFC 3261 grammar.
Generically represents miscellaneous parameter data that is encoded using double quotes.
Represents the "via-received" element in the RFC 3261 grammar.
Represents the "response-port" element of the SIP grammar (as extended in RFC 3581).
Generically represents unsigned 32-bit integer values conveyed by SIP parameters.
Represents a URI enclosed in angle brackets, used in Identity headers for RFC8224.
dcm! – add UnusedChecking(_enum) below;