|
| class | AbandonServerTransaction |
| |
| class | AbstractFifo |
| | The base class from which various templated Fifo classes are derived. More...
|
| |
| struct | AddressMask |
| | An IP address paired with a CIDR prefix length (number of mask bits), for use in address-based access control lists. More...
|
| |
| class | AddTransport |
| |
| class | Aor |
| |
| class | ApiCheck |
| |
| class | AppDialog |
| |
| class | AppDialogSet |
| |
| class | AppDialogSetFactory |
| |
| class | ApplicationMessage |
| | A base-class for messages used by applications. More...
|
| |
| class | ApplicationSip |
| | SIP body type to represent contents with an Content-Type application/sip. More...
|
| |
| class | AresDns |
| |
| class | AsyncProcessHandler |
| |
| class | AsyncResult |
| |
| class | AttributeHelper |
| |
| class | Auth |
| | Represents the "credentials" and "challenge" elements in the SIP grammar. More...
|
| |
| class | Base64Coder |
| |
| class | BaseCreator |
| |
| class | BaseException |
| | The abstract base-class for all exceptions thrown by resip code. More...
|
| |
| class | BaseSecurity |
| |
| class | BaseSubscription |
| | dcm! – update contact in dialog if required More...
|
| |
| class | BaseTimeLimitTimerQueue |
| |
| class | BaseUsage |
| |
| class | BasicDomainMatcher |
| |
| class | BasicNonceHelper |
| | Implements the makeNonce function in the same way as the original implementation of makeNonce within Helper.cxx. More...
|
| |
| class | BasicWsCookieContextFactory |
| |
| class | BranchParameter |
| | Represents the "via-branch" parameter of the RFC 3261 grammar. More...
|
| |
| class | CallID |
| | Represents the "callid" element in the SIP grammar. More...
|
| |
| class | CancelableTimerQueue |
| |
| class | CancelClientInviteTransaction |
| |
| class | CertMessage |
| |
| class | ChallengeInfo |
| |
| struct | CharInfo |
| |
| class | ClientAuthExtension |
| |
| class | ClientAuthManager |
| |
| class | ClientInviteSession |
| |
| class | ClientOutOfDialogReq |
| |
| class | ClientPagerMessage |
| |
| class | ClientPagerMessageHandler |
| |
| class | ClientPublication |
| |
| class | ClientPublicationHandler |
| |
| class | ClientRegistration |
| | dcm! – shutdown/deletion API – end? More...
|
| |
| class | ClientRegistrationHandler |
| |
| class | ClientSubscription |
| | dcm! – update contact in dialog if required More...
|
| |
| class | ClientSubscriptionFunctor |
| |
| class | ClientSubscriptionHandler |
| |
| class | Compression |
| |
| class | ConfigParse |
| |
| class | ConfirmedDialogEvent |
| |
| class | CongestionManager |
| | Abstract base class that provides a basic congestion management interface. More...
|
| |
| class | Connection |
| | Connection implements, via sockets, ConnectionBase for managed connections. More...
|
| |
| class | ConnectionBase |
| |
| class | ConnectionInfo |
| | Facts about a TLS or WebSocket connection that do not change once it is set up. More...
|
| |
| class | ConnectionManager |
| | Collection of Connection per Transport. More...
|
| |
| class | ConnectionTerminated |
| |
| class | ConsumerFifoBuffer |
| |
| class | ContactInstanceRecord |
| | A single contact record, bound to an Aor during registration. More...
|
| |
| class | ContactRecordTransaction |
| | Records a log of the database transacations that were performed when processing a local registration using the ServerRegistration::AsyncLocalStore. More...
|
| |
| class | Contents |
| | Base class for all SIP body types. More...
|
| |
| class | ContentsFactory |
| |
| class | ContentsFactoryBase |
| |
| class | Cookie |
| |
| class | CountBuffer |
| | Implementation of std::streambuf used to back CountStream. More...
|
| |
| class | CountStream |
| | Used to count the amount of data written to a stream. More...
|
| |
| class | CpimContents |
| | SIP body type for holding CPIM (Common Profile for Instant Messaging) contents (MIME content-type message/cpim). More...
|
| |
| class | CSeqCategory |
| | Represents a CSeq header field value (this doesn't have an official name in the RFC 3261 grammar). More...
|
| |
| class | Data |
| | An alternative to std::string, encapsulates an arbitrary buffer of bytes. More...
|
| |
| class | DataBuffer |
| | Implementation of std::streambuf used to back the DataStream, iDataStream, and oDataStream. More...
|
| |
| class | DataException |
| |
| class | DataHelper |
| |
| struct | DataLocalSize |
| |
| class | DataParameter |
| | Generically represents miscellaneous parameter data. More...
|
| |
| class | DataStream |
| | An iostream that operates on an existing Data. More...
|
| |
| class | DateCategory |
| | Represents the "SIP-date" element in the RFC 3261 grammar. More...
|
| |
| class | DayOfWeekHash |
| |
| struct | days |
| |
| class | DefaultServerReferHandler |
| |
| class | DeprecatedDialog |
| |
| class | DestroyUsage |
| |
| class | Dialog |
| | dcm! – kill typedef std::list<DialogId> DialogIdSet; More...
|
| |
| class | DialogEvent |
| |
| class | DialogEventHandler |
| |
| class | DialogEventInfo |
| |
| class | DialogEventStateManager |
| | Implements the FSM for dialog state as spec'd in RFC 4235. More...
|
| |
| class | DialogId |
| |
| class | DialogInfoContents |
| | SIP body type for holding DialogInfo contents (MIME content-type application/dialog-info+xml). More...
|
| |
| class | DialogSet |
| |
| class | DialogSetHandler |
| |
| class | DialogSetId |
| |
| class | DialogUsage |
| |
| class | DialogUsageManager |
| |
| class | DigestBuffer |
| | Implementation of std::streambuf used to back the DigestStream. More...
|
| |
| class | DigestStream |
| | Used to accumlate data written to the stream in a DigestBuffer and convert the data to Digest. More...
|
| |
| class | DinkyPool |
| | A dirt-simple lightweight pool allocator meant for use in short-lifetime objects. More...
|
| |
| class | Dispatcher |
| | A generic thread-bank class. More...
|
| |
| class | DnsAAAARecord |
| |
| class | DnsCnameRecord |
| |
| class | DnsHandler |
| |
| class | DnsHostRecord |
| |
| class | DnsInterface |
| |
| class | DnsNaptrRecord |
| |
| class | DnsRawSink |
| |
| class | DnsResourceRecord |
| |
| class | DNSResult |
| |
| class | DnsResult |
| |
| class | DnsResultMessage |
| |
| class | DnsResultSink |
| |
| class | DnsSrvRecord |
| |
| class | DnsStub |
| |
| class | DnsThread |
| |
| class | DnsUtil |
| | Provides a collection of utility functions for manipulating DNS names and IP addresses and discovering details about the local interfaces. More...
|
| |
| class | DomainMatcher |
| |
| class | DtlsMessage |
| |
| class | DtlsTimerQueue |
| |
| class | DtlsTransport |
| |
| class | DtmfPayloadContents |
| |
| class | DumCommand |
| |
| class | DumCommandAdapter |
| |
| class | DumDecrypted |
| |
| class | DumException |
| |
| class | DumFeature |
| |
| class | DumFeatureChain |
| |
| class | DumFeatureMessage |
| | dcm! – what is the intent of ApplicationMessage, especially as used in More...
|
| |
| class | DumHelper |
| |
| class | DumProcessHandler |
| |
| class | DumShutdownHandler |
| |
| class | DumThread |
| |
| class | DumTimeout |
| |
| class | EarlyDialogEvent |
| |
| class | Embedded |
| |
| class | EnableFlowTimer |
| |
| class | EncryptionManager |
| |
| class | EncryptionRequest |
| |
| class | EnumResult |
| |
| class | EnumResultSink |
| |
| class | EventDispatcher |
| |
| class | EventStackSimpleMgr |
| |
| class | EventStackThread |
| | This class creates a thread in which to run one or more SipStacks. More...
|
| |
| class | EventThreadInterruptor |
| |
| class | ExistsOrDataParameter |
| |
| class | ExistsParameter |
| | Represents various parameters that are indicated to be in effect merely by being present, e.g. More...
|
| |
| class | ExpiresCategory |
| | Represents the header field value for an Expires-type header. More...
|
| |
| class | ExtendedDomainMatcher |
| |
| class | ExtensionHeader |
| |
| class | ExtensionParameter |
| |
| class | ExternalBodyContents |
| | SIP body type to represent contents with an external body (MIME content-type message/external-body). More...
|
| |
| class | ExternalDns |
| |
| class | ExternalDnsCreator |
| |
| class | ExternalDnsFactory |
| |
| class | ExternalDnsHandler |
| |
| class | ExternalDnsHostResult |
| |
| class | ExternalDnsRawResult |
| |
| class | ExternalDnsResult |
| |
| class | ExternalLogger |
| | Interface functor for external logging. More...
|
| |
| class | ExternalMessageBase |
| |
| class | ExternalMessageHandler |
| |
| class | ExternalStatsHandler |
| | Interface functor for external stats handling. More...
|
| |
| class | ExternalTimer |
| |
| class | ExternalTimerHandler |
| |
| class | ExternalUnknownDatagramHandler |
| | Interface functor for external unrecognized datagram handling. More...
|
| |
| class | FdPollGrp |
| |
| class | FdPollImplFdSet |
| |
| class | FdPollItemBase |
| |
| class | FdPollItemFdSetInfo |
| |
| class | FdPollItemIf |
| |
| class | FdSet |
| | Object-oriented wrapper for your platform's file-descriptor set. More...
|
| |
| class | FdSetIOObserver |
| | An interface class for elements that use an FdSet to watch for IO. More...
|
| |
| class | Fifo |
| | A templated, threadsafe message-queue class. More...
|
| |
| class | FifoStatsInterface |
| | Interface for providing metrics on FIFOs, primarily used by CongestionManager. More...
|
| |
| class | FileSystem |
| | Provides file-system traversal. More...
|
| |
| class | FiniteFifo |
| | A templated, threadsafe message-queue class with a fixed size. More...
|
| |
| class | FloatParameter |
| | Generically represents floating point values conveyed by SIP parameters. More...
|
| |
| class | GeneralCongestionManager |
| | This is a general-purpose congestion manager. More...
|
| |
| class | GenericContents |
| | SIP body type for holding generic contents. More...
|
| |
| struct | GenericIPAddress |
| | Represents an IP-address and port (V4 or V6). More...
|
| |
| class | GenericPidfContents |
| | SIP body type for holding PIDF contents (MIME content-type application/pidf+xml). More...
|
| |
| class | GenericTimerQueue |
| |
| class | GenericUri |
| | Represents the "absoluteURI" element in the RFC 3261 grammar. More...
|
| |
| class | GetDnsCacheDumpHandler |
| |
| class | GstSubsystem |
| |
| class | H_ContentDescription |
| | Content-ID MIME header identifier class. More...
|
| |
| class | H_ContentID |
| | Content-ID MIME header identifier class. More...
|
| |
| class | Handle |
| |
| class | Handled |
| |
| class | HandleException |
| |
| class | HandleManager |
| |
| class | HeaderBase |
| |
| class | HeaderFieldValue |
| |
| class | HeaderFieldValueList |
| |
| class | HeaderHash |
| |
| class | Headers |
| | Maps from header name to derived ParserCategory. More...
|
| |
| struct | headers |
| |
| class | HeapInstanceCounter |
| |
| class | Helper |
| | An aggregation of useful static functions. More...
|
| |
| class | HepAgent |
| |
| class | HEPSipMessageLoggingHandler |
| |
| class | HttpGetMessage |
| |
| class | HttpProvider |
| |
| class | HttpProviderFactory |
| |
| struct | HttpRequestOptions |
| |
| class | iDataStream |
| | An istream that operates on an existing Data. More...
|
| |
| class | IdentityCategory |
| | Represents an Identity header from RFC8824. More...
|
| |
| class | IdentityHandler |
| |
| class | InMemoryRegistrationDatabase |
| | Trivial implementation of a persistence manager. More...
|
| |
| class | InMemorySyncPubDb |
| | Implementation of a persistence manager. More...
|
| |
| class | InMemorySyncPubDbHandler |
| |
| class | InMemorySyncRegDb |
| | Implementation of a persistence manager. More...
|
| |
| class | InMemorySyncRegDbHandler |
| |
| class | InserterClass |
| | Allows a (possibly recursive) container of anything with operator<< to be dumped to a stream. More...
|
| |
| class | InserterPClass |
| | Allows a (possibly recursive) container of anything with operator<< to be dumped to a stream. More...
|
| |
| class | IntegerCategory |
| | Represents a numeric-with-comment header field value. More...
|
| |
| class | IntegerParameter |
| | Generically represents integer values conveyed by SIP parameters. More...
|
| |
| class | InternalTransport |
| |
| class | InteropHelper |
| | This class is intended to encapsulate what version/s of various drafts are supported by the stack. More...
|
| |
| class | InterruptableStackThread |
| | This class is used to create a thread to run the SipStack in. More...
|
| |
| class | IntrusiveListElement |
| |
| class | IntrusiveListElement1 |
| |
| class | IntrusiveListElement2 |
| |
| class | IntrusiveListElement3 |
| |
| class | InvalidContents |
| | SIP body type to represent an invalid content type (MIME content-type Invalid/Invalid). More...
|
| |
| class | InviteDialogs |
| |
| class | InviteSession |
| | Base class for class ClientInviteSession and class ServerInviteSession. More...
|
| |
| class | InviteSessionCreator |
| |
| class | InviteSessionHandler |
| |
| class | InvokeAfterSocketCreationFunc |
| |
| class | KeepAliveManager |
| |
| class | KeepAliveMessage |
| |
| class | KeepAlivePong |
| |
| class | KeepAlivePongTimeout |
| |
| class | KeepAliveTimeout |
| |
| struct | KeyedDataHash |
| | Hasher for hash containers keyed by data received from the network, e.g. More...
|
| |
| class | KeyValueStore |
| |
| class | LazyParser |
| | The base-class for all lazily-parsed SIP grammar elements. More...
|
| |
| class | LinkedHashMap |
| | A hash map that iterates in insertion order, so a container filled while parsing (eg. More...
|
| |
| class | LocalDns |
| |
| class | Log |
| | Singleton that handles logging calls. More...
|
| |
| class | LogStaticInitializer |
| | Class to initialize Log class static variables. More...
|
| |
| class | MacSecurity |
| |
| class | MarkListener |
| |
| class | MasterProfile |
| |
| class | MD5Buffer |
| | Implementation of std::streambuf used to back the MD5Stream. More...
|
| |
| struct | MD5Context |
| |
| class | MD5Stream |
| | Used to accumlate data written to the stream in a MD5Buffer and convert the data to MD5. More...
|
| |
| class | MediaConstants |
| |
| class | MediaControlContents |
| |
| class | MergedRequestKey |
| |
| class | MergedRequestRemovalCommand |
| |
| class | Message |
| | The base-class used for message-passing. More...
|
| |
| class | MessageDecorator |
| |
| class | MessageFilterRule |
| |
| class | MessageId |
| |
| class | MessageWaitingContents |
| | SIP body type for holding MWI contents (MIME content-type application/simple-message-summary). More...
|
| |
| class | MethodHash |
| |
| struct | methods |
| |
| class | Mime |
| | Represents the "media-type" element in the RFC 3261 grammar. More...
|
| |
| class | MIME_Header |
| | MIME header identifier base class. More...
|
| |
| class | MonthHash |
| |
| struct | months |
| |
| class | MsgHeaderScanner |
| |
| class | MultipartAlternativeContents |
| | SIP body type for holding Multipart-Alternative body contents (MIME content-type multipart/alternative). More...
|
| |
| class | MultipartMixedContents |
| | SIP body type for holding Multipart-Mixed body contents (MIME content-type multipart/mixed). More...
|
| |
| class | MultipartRelatedContents |
| | SIP body type for holding Multipart-Related body contents (MIME content-type multipart/related). More...
|
| |
| class | MultipartSignedContents |
| | SIP body type for holding Multipart-Signed body contents (MIME content-type multipart/signed). More...
|
| |
| class | MultipleEventDialogEvent |
| |
| class | NameAddr |
| | Represents the "name-addr" and the "addr-spec" elements in the RFC 3261 grammar. More...
|
| |
| class | NetworkAssociation |
| |
| class | NonceHelper |
| |
| class | NonDialogUsage |
| |
| class | OctetContents |
| | SIP body type for holding Octet contents (MIME content-type application/octet-stream). More...
|
| |
| class | oDataStream |
| | An ostream that operates on an existing Data. More...
|
| |
| struct | OpenSSLDeleter |
| |
| class | OpenSSLInit |
| |
| class | OutgoingEvent |
| |
| class | OutOfDialogHandler |
| |
| class | OutOfDialogReqCreator |
| |
| class | PagerMessageCreator |
| |
| class | Param |
| |
| class | ParamBase |
| |
| class | Parameter |
| |
| class | ParameterHash |
| |
| class | ParameterTypes |
| | This is one of the places where new parameter types must be defined. More...
|
| |
| struct | params |
| |
| class | ParseBuffer |
| | Provides string-parsing functionality with protection from buffer overflow. More...
|
| |
| class | ParseException |
| | BaseException used to indicate parse failures. More...
|
| |
| class | ParserCategory |
| | Base class for all SIP grammar elements that can have parameters. More...
|
| |
| class | ParserContainer |
| | Container class for ParserCategory, used by SipMessage to represent multi-valued headers (Contact, Via, etc). More...
|
| |
| class | ParserContainerBase |
| | Abstract Base class implemented in derived class ParserContainer. More...
|
| |
| class | Pidf |
| | Deprecated. More...
|
| |
| class | Pkcs7Contents |
| | SIP body type for holding PKCS7 contents (MIME content-type application/pkcs7-mime). More...
|
| |
| class | Pkcs7SignedContents |
| | SIP body type for holding PKCS7 Signed contents (MIME content-type application/pkcs7-signature). More...
|
| |
| class | Pkcs8Contents |
| | SIP body type for holding PKCS8 contents (MIME content-type application/pkcs8). More...
|
| |
| class | PlainContents |
| | SIP body type for holding plain contents (MIME content-type text/plain). More...
|
| |
| class | Plugin |
| |
| class | PluginManager |
| |
| class | Poll |
| | This class abstracts the Unix system call "poll". More...
|
| |
| class | PollImpl |
| |
| class | PollStatistics |
| |
| class | PoolBase |
| |
| class | Postable |
| |
| class | PrivacyCategory |
| | Represents the "token" element in the RFC 3261 grammar. More...
|
| |
| class | ProceedingDialogEvent |
| |
| class | ProducerFifoBuffer |
| | Class for buffering messages placed in a Fifo, to be used by a single producer. More...
|
| |
| class | Profile |
| |
| class | ProtonThreadBase |
| |
| class | PtrLock |
| | Much like class Lock above, but takes pointer argument to Lockable, which may be NULL. More...
|
| |
| class | PublicationCreator |
| |
| class | PublicationPersistenceManager |
| | Abstract interface of a datastore of all publication documents processed by DUM. More...
|
| |
| class | PyExtensionBase |
| |
| class | PyExternalUser |
| |
| class | PyThreadSupport |
| |
| class | QuotedDataParameter |
| | Generically represents miscellaneous parameter data that is encoded using double quotes. More...
|
| |
| class | QValue |
| |
| class | QValueParameter |
| | Represents the "q" parameter value of the RFC 3261 grammar. More...
|
| |
| class | RAckCategory |
| | Represents the RAck header field value defined in the RFC 3262 grammar. More...
|
| |
| class | Random |
| | A static class that wraps the random-number generation code of your platform. More...
|
| |
| class | ReadLock |
| |
| class | ReceivedParameter |
| | Represents the "via-received" element in the RFC 3261 grammar. More...
|
| |
| class | RedirectHandler |
| |
| class | RedirectManager |
| |
| class | RefCountedDestroyer |
| |
| class | RegistrationBinding |
| |
| struct | RegistrationBindingDelta |
| |
| class | RegistrationCreator |
| | This class creates registration requests on behalf of a client. More...
|
| |
| class | RegistrationPersistenceManager |
| | Abstract interface of a datastore of all registered endpoints processed by DUM. More...
|
| |
| class | RemoteCertStore |
| |
| class | RemoveTransport |
| |
| class | RequestLine |
| | Represents the "Request-Line" element in the RFC 3261 grammar. More...
|
| |
| class | RequestLineType |
| |
| class | RequestValidationHandler |
| | Handler used to know when an incoming request failed validation. More...
|
| |
| class | ResipBasicIOStream |
| |
| class | ResipClock |
| | Clock used for timing in the Timer class and possibly other areas. More...
|
| |
| class | ResipFastIStream |
| | std::istream replacement More...
|
| |
| class | ResipFastOStream |
| | std::ostream replacement. More...
|
| |
| class | ResipStdBuf |
| | Used to replace std::cerr, std::cout, etc. More...
|
| |
| class | ResipStdCOStream |
| | A direct replacement for std::cout, std::cerr, etc. More...
|
| |
| class | ResipStreamBuf |
| |
| class | Rlmi |
| | SIP body type for holding RLMI contents (MIME content-type application/rlmi+xml). More...
|
| |
| class | RportParameter |
| | Represents the "response-port" element of the SIP grammar (as extended in RFC 3581). More...
|
| |
| class | RRCache |
| |
| class | RRFactory |
| |
| class | RRFactoryBase |
| |
| class | RRList |
| |
| class | RROverlay |
| |
| class | RRVip |
| |
| class | RTPPortManager |
| |
| class | RWMutex |
| | Wraps the readers/writers mutex implementation on your platform. More...
|
| |
| class | SdpContents |
| | Provides an interface to process and generate SDP bodies (MIME content-type application/sdp). More...
|
| |
| class | Security |
| |
| class | SecurityAttributes |
| |
| class | SelectInterruptor |
| | Used to 'artificially' interrupt a select call. More...
|
| |
| class | SendData |
| |
| class | SERNonceHelper |
| |
| class | ServerAuthManager |
| |
| class | ServerInviteSession |
| |
| class | ServerOutOfDialogReq |
| |
| class | ServerPagerMessage |
| |
| class | ServerPagerMessageHandler |
| |
| class | ServerProcess |
| |
| class | ServerPublication |
| |
| class | ServerPublicationHandler |
| |
| class | ServerRegistration |
| |
| class | ServerRegistrationHandler |
| |
| class | ServerSubscription |
| | dcm! – no Subscription State expires parameter generation yet. More...
|
| |
| class | ServerSubscriptionFunctor |
| |
| class | ServerSubscriptionHandler |
| |
| class | Sha1 |
| |
| class | SHA1Buffer |
| | An implementation of std::streambuf used to back the SHA1Stream. More...
|
| |
| class | SHA1Stream |
| | Used to accumlate data written to the stream in a SHA1Buffer and convert the data to SHA1. More...
|
| |
| class | ShutdownMessage |
| |
| class | SipConfigParse |
| |
| class | SipFrag |
| | SIP body type for holding SipFrag contents (MIME content-type message/sipfrag). More...
|
| |
| class | SipMessage |
| | Represents a SIP message. More...
|
| |
| class | SipStack |
| | This is the primary point of interaction between the app-layer and the stack. More...
|
| |
| class | SipStackOptions |
| | This class holds constructor-time initialization arguments for SipStack. More...
|
| |
| class | StackThread |
| | This class is used to create a thread to run the SipStack in. More...
|
| |
| class | StartLine |
| |
| class | StatelessHandler |
| |
| class | StatelessMessage |
| |
| class | StatisticsManager |
| | Keeps track of various statistics on the stack's operation, and periodically issues a StatisticsMessage to the TransactionUser (or, if the ExternalStatsHandler is set, it will be sent there). More...
|
| |
| class | StatisticsMessage |
| |
| class | StatusLine |
| | Represents the "Status-Line" element in the RFC 3261 grammar. More...
|
| |
| class | StatusLineType |
| |
| class | StlPoolAllocator |
| | A dirt-simple lightweight stl pool allocator meant for use in short-lifetime objects. More...
|
| |
| class | StringCategory |
| | Represents the "header-value" element in the RFC 3261 grammar (ie, an unknown header field value). More...
|
| |
| struct | StunAddress4 |
| |
| struct | StunAtrAddress4 |
| |
| struct | StunAtrChangeRequest |
| |
| struct | StunAtrError |
| |
| struct | StunAtrHdr |
| |
| struct | StunAtrIntegrity |
| |
| struct | StunAtrString |
| |
| struct | StunAtrUnknown |
| |
| struct | StunMediaRelay |
| |
| struct | StunMessage |
| |
| struct | StunMsgHdr |
| |
| struct | StunServerInfo |
| |
| class | SubscriptionCreator |
| |
| class | SubscriptionPersistenceManager |
| |
| class | Subsystem |
| | Class used to specify what sub-system given sections of code belong to, for use by the logging system. More...
|
| |
| class | Symbols |
| |
| class | SysLogBuf |
| |
| class | SysLogStream |
| |
| class | TargetCommand |
| |
| class | TcpBaseTransport |
| |
| class | TcpConnection |
| |
| class | TcpConnectState |
| | This message is used to indicate to the transaction state that a TCP based transport is trying to TCP Connect or has completed a TCP connect. More...
|
| |
| class | TcpTransport |
| |
| class | TerminatedDialogEvent |
| |
| class | TerminateFlow |
| |
| class | ThreadIf |
| | A wrapper class to create and spawn a thread. More...
|
| |
| class | TimeAccumulate |
| | Accumulates time and count by distinct string. More...
|
| |
| class | TimeLimitFifo |
| |
| class | TimeLimitTimerQueue |
| |
| class | Timer |
| | This class is used to get the current system time. More...
|
| |
| class | TimerMessage |
| |
| class | TimerQueue |
| |
| class | TimerWithPayload |
| |
| class | Timestamped |
| | wraps an object with a timestamp More...
|
| |
| class | TlsBaseTransport |
| |
| class | TlsConnection |
| |
| class | TlsPeerAuthManager |
| |
| class | TlsPeerIdentityInfoMessage |
| |
| class | TlsTransport |
| |
| class | Token |
| | Represents the "token" element in the RFC 3261 grammar. More...
|
| |
| class | TokenOrQuotedStringCategory |
| | Generically represents a token whose value can be wrapped and encoded using double quotes. More...
|
| |
| class | TransactionController |
| |
| class | TransactionControllerThread |
| |
| class | TransactionMap |
| |
| class | TransactionMessage |
| |
| class | TransactionState |
| |
| class | TransactionTerminated |
| |
| class | TransactionTimer |
| |
| class | TransactionTimerQueue |
| |
| class | TransactionUser |
| | The base-class for an RFC 3261 Transaction User. More...
|
| |
| class | TransactionUserMessage |
| |
| struct | TransitionInfo |
| |
| class | Transport |
| | The base class for Transport classes. More...
|
| |
| class | TransportFailure |
| | This message is used to indicate that the TransportSelector has sent a sip message using either reliable or unreliable transport. More...
|
| |
| class | TransportSelector |
| |
| class | TransportSelectorThread |
| |
| class | TransportThread |
| |
| class | TrickleIceContents |
| |
| class | TryingDialogEvent |
| |
| class | TuIM |
| |
| class | Tuple |
| | Represents a network address. More...
|
| |
| class | TupleMarkManager |
| |
| class | TuSelector |
| |
| class | TuSelectorTimerQueue |
| |
| class | UdpTransport |
| | A Transport based on UDP. More...
|
| |
| struct | UInt128 |
| |
| class | UInt32Category |
| | Represents a numeric-with-comment header field value. More...
|
| |
| class | UInt32Parameter |
| | Generically represents unsigned 32-bit integer values conveyed by SIP parameters. More...
|
| |
| class | UnknownParameter |
| | Generically used to represent any parameter that is not known by the implmentation. More...
|
| |
| class | Uri |
| | Represents the "SIP-URI" and "SIPS-URI" elements in the RFC 3261 grammar. More...
|
| |
| class | UriParameter |
| | Represents a URI enclosed in angle brackets, used in Identity headers for RFC8224. More...
|
| |
| class | UsageUseException |
| |
| class | UserAuthInfo |
| |
| class | UserProfile |
| |
| class | ValueFifo |
| |
| class | Via |
| | Represents the "via-parm" element in the RFC 3261 grammar. More...
|
| |
| class | WarningCategory |
| | Represents the "warning-value" element in the RFC 3261 grammar. More...
|
| |
| class | WinSecurity |
| | WARNING - This class is only appropriate for client TLS connections, as it only loads root certs. More...
|
| |
| class | Worker |
| |
| class | WorkerThread |
| |
| class | WriteLock |
| |
| class | WsBaseTransport |
| |
| class | WsConnection |
| |
| class | WsConnectionBase |
| |
| class | WsConnectionValidator |
| |
| class | WsCookieAuthManager |
| |
| class | WsCookieContext |
| |
| class | WsCookieContextFactory |
| |
| class | WsDecorator |
| |
| class | WsFrameExtractor |
| |
| class | WssConnection |
| |
| class | WssTransport |
| |
| class | WsTransport |
| |
| class | X509Contents |
| | SIP body type for holding X509 contents (MIME content-type application/pkix-cert). More...
|
| |
| class | XMLCursor |
| |
| class | ZeroOutStatistics |
| |
|
| EncodeStream & | operator<< (EncodeStream &strm, const BaseException &e) |
| |
| std::ostream & | operator<< (std::ostream &strm, const BaseException &e) |
| |
| template<typename _Tp > |
| const _Tp & | resipMin (const _Tp &__a, const _Tp &__b) |
| |
| template<typename _Tp > |
| const _Tp & | resipMax (const _Tp &__a, const _Tp &__b) |
| |
| template<typename _Tp1 , typename _Tp2 > |
| const _Tp1 | resipIntDiv (const _Tp1 &__a, const _Tp2 &__b) |
| |
| uint64_t | ntoh64 (const uint64_t input) |
| |
| uint64_t | hton64 (const uint64_t input) |
| |
| const char * | strErrorResult (char *result, char *) |
| |
| const char * | strErrorResult (int result, char *buf) |
| |
| std::string | strError (int err) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const ConfigParse &config) |
| |
| bool | isEqualNoCase (const Data &left, const Data &right) |
| |
| bool | isTokenEqualNoCase (const Data &left, const Data &right) |
| |
| bool | isLessThanNoCase (const Data &left, const Data &right) |
| |
| bool | operator!= (const Data &lhs, const Data &rhs) |
| |
| bool | operator> (const Data &lhs, const Data &rhs) |
| |
| bool | operator<= (const Data &lhs, const Data &rhs) |
| |
| bool | operator>= (const Data &lhs, const Data &rhs) |
| |
| bool | operator!= (const Data &lhs, const char *rhs) |
| |
| bool | operator> (const Data &lhs, const char *rhs) |
| |
| bool | operator<= (const Data &lhs, const char *rhs) |
| |
| bool | operator>= (const Data &lhs, const char *rhs) |
| |
| bool | operator== (const char *lhs, const Data &rhs) |
| |
| bool | operator!= (const char *lhs, const Data &rhs) |
| |
| bool | operator> (const char *lhs, const Data &rhs) |
| |
| bool | operator<= (const char *lhs, const Data &rhs) |
| |
| bool | operator>= (const char *lhs, const Data &rhs) |
| |
| bool | operator!= (const Data &lhs, const std::string &rhs) noexcept |
| |
| bool | operator> (const Data &lhs, const std::string &rhs) |
| |
| bool | operator<= (const Data &lhs, const std::string &rhs) |
| |
| bool | operator>= (const Data &lhs, const std::string &rhs) |
| |
| bool | operator== (const std::string &lhs, const Data &rhs) noexcept |
| |
| bool | operator!= (const std::string &lhs, const Data &rhs) noexcept |
| |
| bool | operator> (const std::string &lhs, const Data &rhs) |
| |
| bool | operator<= (const std::string &lhs, const Data &rhs) |
| |
| bool | operator>= (const std::string &lhs, const Data &rhs) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Data &d) |
| |
| std::ostream & | operator<< (std::ostream &strm, const Data &d) |
| |
| Data | operator+ (const char *c, const Data &d) |
| |
| bool | operator== (const Data &lhs, const Data &rhs) |
| |
| bool | operator== (const Data &lhs, const char *rhs) |
| |
| bool | operator== (const Data &lhs, const std::string &rhs) noexcept |
| |
| bool | operator< (const Data &lhs, const Data &rhs) |
| |
| bool | operator< (const Data &lhs, const char *rhs) |
| |
| bool | operator< (const char *lhs, const Data &rhs) |
| |
| bool | operator< (const Data &lhs, const std::string &rhs) noexcept |
| |
| bool | operator< (const std::string &lhs, const Data &rhs) noexcept |
| |
| size_t | hashCombine (size_t seed, size_t hash) |
| | Combines the hashes of the parts of a composite key, eg.
|
| |
| EncodeStream & | operator<< (EncodeStream &strm, DnsResourceRecord &rr) |
| |
| template<class T > |
| EncodeStream & | operator<< (EncodeStream &strm, const DNSResult< T > &r) |
| |
| | defineQueryType (A, DnsHostRecord, 1, true, "RFC 1035") |
| |
| | defineQueryType (CNAME, DnsCnameRecord, 5, false, "RFC 1035") |
| |
| | defineQueryType (AAAA, DnsAAAARecord, 28, true, "RFC 3596") |
| |
| | defineQueryType (SRV, DnsSrvRecord, 33, true, "RFC 2782") |
| |
| | defineQueryType (NAPTR, DnsNaptrRecord, 35, true, "RFC 2915") |
| |
| EncodeStream & | operator<< (EncodeStream &ostrm, const GenericIPAddress &addr) |
| |
| static const char * | leftanglebracket ("<") |
| |
| static const char * | rightanglebracket (">") |
| |
| static const char * | leftsqbracket ("[") |
| |
| static const char * | rightsqbracket ("]") |
| |
| static const char * | sparrowsp (" -> ") |
| |
| static const char * | commaspace (", ") |
| |
| template<class T > |
| EncodeStream & | insert (EncodeStream &s, const std::vector< T > &c) |
| | Completely generic insert function.
|
| |
| template<class T > |
| EncodeStream & | insert (EncodeStream &s, const std::deque< T > &c) |
| |
| template<class T > |
| EncodeStream & | insert (EncodeStream &s, const std::list< T > &c) |
| |
| template<class K , class C > |
| EncodeStream & | insert (EncodeStream &s, const std::set< K, C > &c) |
| |
| template<class K , class C > |
| EncodeStream & | insert (EncodeStream &s, const std::multiset< K, C > &c) |
| |
| template<class K , class V , class H > |
| EncodeStream & | insert (EncodeStream &s, const std::unordered_map< K, V, H > &c) |
| |
| template<class V , class H > |
| EncodeStream & | insert (EncodeStream &s, const std::unordered_set< V, H > &c) |
| |
| template<class K , class V , class H , class P > |
| EncodeStream & | insert (EncodeStream &s, const LinkedHashMap< K, V, H, P > &c) |
| |
| template<class K , class V , class H > |
| EncodeStream & | insert (EncodeStream &s, const std::map< K, V, H > &c) |
| |
| template<class T > |
| EncodeStream & | insert (EncodeStream &s, const std::basic_string< T > &str) |
| |
| template<class T , class U > |
| EncodeStream & | insert (EncodeStream &s, const std::pair< T, U > &p) |
| |
| template<class T > |
| EncodeStream & | operator<< (EncodeStream &s, const InserterClass< T > &inserter) |
| | Function to allow an Inserter to be used directly with a stream.
|
| |
| template<class T > |
| InserterClass< T > | Inserter (const T &t) |
| | Templatized function to construct an instance of InserterClass for a container to be inserted.
|
| |
| template<class T > |
| EncodeStream & | insertP (EncodeStream &s, const std::vector< T > &c) |
| | The following functions are more or less the same as the above, but add P to the naming and treat data items as pointers.
|
| |
| template<class T > |
| EncodeStream & | insertP (EncodeStream &s, const std::deque< T > &c) |
| |
| template<class T > |
| EncodeStream & | insertP (EncodeStream &s, const std::list< T > &c) |
| |
| template<class K , class C > |
| EncodeStream & | insertP (EncodeStream &s, const std::set< K, C > &c) |
| |
| template<class K , class C > |
| EncodeStream & | insertP (EncodeStream &s, const std::multiset< K, C > &c) |
| |
| template<class K , class V , class H > |
| EncodeStream & | insertP (EncodeStream &s, const std::unordered_map< K, V, H > &c) |
| |
| template<class V , class H > |
| EncodeStream & | insertP (EncodeStream &s, const std::unordered_set< V, H > &c) |
| |
| template<class K , class V , class H > |
| EncodeStream & | insertP (EncodeStream &s, const std::map< K, V, H > &c) |
| |
| template<class T > |
| EncodeStream & | insertP (EncodeStream &s, const std::basic_string< T > &str) |
| |
| template<class T , class U > |
| EncodeStream & | insertP (EncodeStream &s, const std::pair< T, U > &p) |
| |
| template<class T > |
| EncodeStream & | operator<< (EncodeStream &s, const InserterPClass< T > &inserter) |
| | Function to allow an Inserter to be used directly with a stream.
|
| |
| template<class T > |
| InserterPClass< T > | InserterP (const T &t) |
| | Templatized function to construct an instance of InserterClass for a container to be inserted.
|
| |
| EncodeStream & | operator<< (EncodeStream &strm, const KeyValueStore &store) |
| |
| resip::ResipFastOStream & | operator<< (resip::ResipFastOStream &ostr, const char *str) |
| |
| resip::ResipFastOStream & | operator<< (resip::ResipFastOStream &ostr, char ch) |
| |
| resip::ResipFastOStream & | operator<< (resip::ResipFastOStream &ostr, unsigned char ch) |
| |
| resip::ResipFastOStream & | operator<< (resip::ResipFastOStream &ostr, const unsigned char *str) |
| |
| resip::ResipFastOStream & | operator<< (resip::ResipFastOStream &ostr, signed char ch) |
| |
| resip::ResipFastOStream & | operator<< (resip::ResipFastOStream &ostr, const signed char *str) |
| |
| resip::ResipFastOStream & | operator<< (resip::ResipFastOStream &ostr, const std::string &str) |
| |
| template<typename T > |
| ResipFastOStream & | operator<< (ResipFastOStream &os, const std::shared_ptr< T > &ptr) |
| |
| void | initNetwork () |
| | set up network - does nothing in unix but needed for windows
|
| |
| int | getErrno () |
| |
| bool | makeSocketNonBlocking (Socket fd) |
| |
| bool | makeSocketBlocking (Socket fd) |
| |
| bool | configureConnectedSocket (Socket fd) |
| |
| int | closeSocket (Socket fd) |
| |
| int | getSocketError (Socket fd) |
| |
| int | increaseLimitFds (unsigned int targetFds) |
| | Returns negative on error, or number of (positive) allowed fds.
|
| |
| int | setSocketRcvBufLen (Socket fd, int buflen) |
| |
| int | setSocketDscp (Socket fd, int dscp, IpVersion version) |
| | Sets the DSCP class of {fd}, in the IPv4 ToS byte or the IPv6 traffic class, and reads it back.
|
| |
| int | getSocketTos (Socket fd, IpVersion version) |
| | Reads the IPv4 ToS byte, or the IPv6 traffic class, of {fd}.
|
| |
| int | getSocketDscp (Socket fd, IpVersion version) |
| | The DSCP class of {fd}, which is getSocketTos() without the ECN bits.
|
| |
| long | parseOpenSSLCTXOption (const Data &optionName) |
| | Converts an OpenSSL option name (eg.
|
| |
| static bool | stunParseAtrAddress (char *body, unsigned int hdrLen, StunAtrAddress4 &result) |
| |
| static bool | stunParseUInt32 (char *body, unsigned int hdrLen, uint32_t &result) |
| |
| static bool | stunParseAtrChangeRequest (char *body, unsigned int hdrLen, StunAtrChangeRequest &result) |
| |
| static bool | stunParseAtrError (char *body, unsigned int hdrLen, StunAtrError &result) |
| |
| static bool | stunParseAtrUnknown (char *body, unsigned int hdrLen, StunAtrUnknown &result) |
| |
| static bool | stunParseAtrString (char *body, unsigned int hdrLen, StunAtrString &result) |
| |
| static bool | stunParseAtrUInt32 (char *body, unsigned int hdrLen, uint32_t &result) |
| |
| static bool | stunParseAtrIntegrity (char *body, unsigned int hdrLen, StunAtrIntegrity &result) |
| |
| bool | stunParseMessage (char *buf, unsigned int bufLen, StunMessage &msg, bool verbose) |
| |
| static char * | encode16 (char *buf, uint16_t data) |
| |
| static char * | encode32 (char *buf, uint32_t data) |
| |
| static char * | encode (char *buf, const char *data, unsigned int length) |
| |
| static char * | encodeTurnData (char *ptr, const resip::Data *td) |
| |
| static char * | encodeAtrUInt32 (char *ptr, uint16_t type, uint32_t value) |
| |
| static char * | encodeAtrAddress4 (char *ptr, uint16_t type, const StunAtrAddress4 &atr) |
| |
| static char * | encodeAtrChangeRequest (char *ptr, const StunAtrChangeRequest &atr) |
| |
| static char * | encodeMagicCookie (char *ptr, const uint32_t &cookie) |
| |
| static char * | encodeAtrError (char *ptr, const StunAtrError &atr) |
| |
| static char * | encodeAtrUnknown (char *ptr, const StunAtrUnknown &atr) |
| |
| static char * | encodeXorOnly (char *ptr) |
| |
| static char * | encodeAtrString (char *ptr, uint16_t type, const StunAtrString &atr) |
| |
| static char * | encodeAtrIntegrity (char *ptr, const StunAtrIntegrity &atr) |
| |
| unsigned int | stunEncodeMessage (const StunMessage &msg, char *buf, unsigned int bufLen, const StunAtrString &password, bool verbose) |
| |
| int | stunRand () |
| |
| int | stunRandomPort () |
| | return a random number to use as a port
|
| |
| void | computeHmac (char *hmac, const char *input, int length, const char *key, int sizeKey) |
| |
| bool | stunVerifyMessageIntegrity (const char *buf, unsigned int bufLen, const StunMessage &message, const StunAtrString &password) |
| | Verify the MESSAGE-INTEGRITY attribute of a parsed message against the supplied short-term credential password, using a constant-time comparison.
|
| |
| static void | toHex (const char *buffer, int bufferSize, char *output) |
| |
| void | stunCreateUserName (const StunAddress4 &source, StunAtrString *username) |
| |
| void | stunCreatePassword (const StunAtrString &username, StunAtrString *password) |
| |
| uint64_t | stunGetSystemTimeSecs () |
| |
| ostream & | operator<< (ostream &strm, const UInt128 &r) |
| |
| ostream & | operator<< (std::ostream &strm, const StunAddress4 &addr) |
| | prints a StunAddress
|
| |
| ostream & | operator<< (ostream &os, const StunMsgHdr &h) |
| |
| bool | stunParseHostName (char *peerName, uint32_t &ip, uint16_t &portVal, uint16_t defaultPort) |
| |
| bool | stunParseServerName (char *software, StunAddress4 &stunServerAddr) |
| | find the IP address of a the specified stun server - return false is fails parse
|
| |
| static void | stunCreateErrorResponse (StunMessage &response, int cl, int number, const char *msg) |
| |
| static void | stunCreateSharedSecretResponse (const StunMessage &request, const StunAddress4 &source, StunMessage &response) |
| |
| bool | stunServerProcessMsg (char *buf, unsigned int bufLen, StunAddress4 &from, StunAddress4 &secondary, StunAddress4 &myAddr, StunAddress4 &altAddr, StunMessage *resp, StunAddress4 *destination, StunAtrString *hmacPassword, bool *changePort, bool *changeIp, bool verbose) |
| |
| bool | stunInitServer (StunServerInfo &info, const StunAddress4 &myAddr, const StunAddress4 &altAddr, int startMediaPort, bool verbose) |
| | return true if all is OK Create a media relay and do the STERN thing if startMediaPort is non-zero
|
| |
| void | stunStopServer (StunServerInfo &info) |
| |
| bool | stunServerProcess (StunServerInfo &info, bool verbose) |
| | return true if all is OK
|
| |
| int | stunFindLocalInterfaces (uint32_t *addresses, int maxSize) |
| | returns number of address found - take array or addres
|
| |
| void | stunBuildReqSimple (StunMessage *msg, const StunAtrString &username, bool changePort, bool changeIp, unsigned int id) |
| |
| static void | stunSendTest (resip::Socket myFd, StunAddress4 &dest, const StunAtrString &username, const StunAtrString &password, int testNum, bool verbose) |
| |
| void | stunGetUserNameAndPassword (const StunAddress4 &dest, StunAtrString *username, StunAtrString *password) |
| |
| bool | stunTest (StunAddress4 &dest, int testNum, bool verbose, StunAddress4 *sAddr, unsigned long timeoutMs) |
| |
| NatType | stunNatType (StunAddress4 &dest, bool verbose, bool *preservePort, bool *hairpin, int port, StunAddress4 *sAddr) |
| |
| int | stunOpenSocket (StunAddress4 &dest, StunAddress4 *mapAddr, int port, StunAddress4 *srcAddr, bool verbose) |
| |
| bool | stunOpenSocketPair (StunAddress4 &dest, StunAddress4 *mapAddr, int *fd1, int *fd2, int port, StunAddress4 *srcAddr, bool verbose) |
| |
| bool | operator< (const UInt128 &lhs, const UInt128 &rhs) |
| |
| bool | operator== (const UInt128 &lhs, const UInt128 &rhs) |
| |
| bool | operator< (const StunMsgHdr &lhs, const StunMsgHdr &rhs) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Subsystem &ss) |
| |
| std::ostream & | operator<< (std::ostream &os, const resip::Log::Level &level) |
| |
| void | sleepMs (unsigned int ms) |
| |
| void | sleepSeconds (unsigned int seconds) |
| |
| std::ostream & | operator<< (std::ostream &str, const TransactionTimer &t) |
| |
| std::ostream & | operator<< (std::ostream &str, const TimerWithPayload &t) |
| |
| EncodeStream & | operator<< (EncodeStream &str, const TransactionTimer &t) |
| |
| EncodeStream & | operator<< (EncodeStream &str, const TimerWithPayload &t) |
| |
| TransportType | getTransportTypeFromName (const std::string &transportName) |
| | Function which translates a transport name to its corrisponding integer enum value.
|
| |
| TransportType | toTransportType (const resip::Data &transportName) |
| |
| std::string | getTransportNameFromType (const TransportType typeEnum) |
| | Function which translates a transport enum value to its corrisponding name.
|
| |
| std::string | getTransportNameFromTypeLower (const TransportType typeEnum) |
| |
| const resip::Data & | toData (const TransportType typeEnum) |
| |
| const resip::Data & | toDataLower (const TransportType typeEnum) |
| |
| bool | isReliable (TransportType type) |
| | Returns true if passed in transport type is a reliable transport protocol.
|
| |
| bool | isSecure (TransportType type) |
| | Returns true if passed in transport type is a secure transport protocol.
|
| |
| bool | isWebSocket (TransportType type) |
| | Returns true if passed in transport type is a WebSocket transport protocol.
|
| |
| void | MD5Init (struct MD5Context *context) |
| |
| void | MD5Update (struct MD5Context *context, md5byte const *buf, unsigned len) |
| |
| void | MD5Final (unsigned char digest[16], struct MD5Context *context) |
| |
| void | MD5Transform (u_int32_t buf[4], u_int32_t const in[16]) |
| |
| void | byteSwap (u_int32_t *buf, unsigned words) |
| |
| EncodeStream & | operator<< (EncodeStream &str, const XMLCursor &cursor) |
| |
| EncodeStream & | operator<< (EncodeStream &str, const XMLCursor::Node &cursor) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const resip::Connection &c) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const resip::ConnectionBase &c) |
| |
| bool | operator== (const Contents &lhs, const Contents &rhs) |
| |
| bool | operator!= (const Contents &lhs, const Contents &rhs) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Cookie &c) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const DeprecatedDialog &d) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const DnsResult &) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const DnsResult::SRV &) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const DnsResult::NAPTR &) |
| |
| static int | gperf_case_strncmp (const char *s1, const char *s2, size_t n) |
| |
| static int | gperf_case_strncmp (const char *s1, const char *s2, size_t n) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const GenericPidfContents::SimplePresenceInfo &tuple) |
| |
| EncodeStream & | operator<< (EncodeStream &stream, HeaderFieldValue &hList) |
| |
| | defineHeader (ContentDisposition, "Content-Disposition", Token, "RFC 3261") |
| |
| | defineHeader (ContentEncoding, "Content-Encoding", Token, "RFC 3261") |
| |
| | defineHeader (MIMEVersion, "Mime-Version", Token, "RFC 3261") |
| |
| | defineHeader (Priority, "Priority", Token, "RFC 3261") |
| |
| | defineHeader (Event, "Event", Token, "RFC 3265") |
| |
| | defineHeader (SubscriptionState, "Subscription-State", Token, "RFC 3265") |
| |
| | defineHeader (SIPETag, "SIP-ETag", Token, "RFC 3903") |
| |
| | defineHeader (SIPIfMatch, "SIP-If-Match", Token, "RFC 3903") |
| |
| | defineHeader (ContentId, "Content-ID", Token, "RFC 2045") |
| |
| | defineMultiHeader (AllowEvents, "Allow-Events", Token, "RFC 3265") |
| |
| | defineMultiHeader (AcceptEncoding, "Accept-Encoding", Token, "RFC 3261") |
| |
| | defineMultiHeader (AcceptLanguage, "Accept-Language", Token, "RFC 3261") |
| |
| | defineMultiHeader (Allow, "Allow", Token, "RFC 3261") |
| |
| | defineMultiHeader (ContentLanguage, "Content-Language", Token, "RFC 3261") |
| |
| | defineMultiHeader (ProxyRequire, "Proxy-Require", Token, "RFC 3261") |
| |
| | defineMultiHeader (Require, "Require", Token, "RFC 3261") |
| |
| | defineMultiHeader (Supported, "Supported", Token, "RFC 3261") |
| |
| | defineMultiHeader (Unsupported, "Unsupported", Token, "RFC 3261") |
| |
| | defineMultiHeader (SecurityClient, "Security-Client", Token, "RFC 3329") |
| |
| | defineMultiHeader (SecurityServer, "Security-Server", Token, "RFC 3329") |
| |
| | defineMultiHeader (SecurityVerify, "Security-Verify", Token, "RFC 3329") |
| |
| | defineMultiHeader (RequestDisposition, "Request-Disposition", Token, "RFC 3841") |
| |
| | defineMultiHeader (Reason, "Reason", Token, "RFC 3326") |
| |
| | defineMultiHeader (Privacy, "Privacy", PrivacyCategory, "RFC 3323") |
| |
| | defineMultiHeader (PMediaAuthorization, "P-Media-Authorization", Token, "RFC 3313") |
| |
| | defineHeader (ReferSub, "Refer-Sub", Token, "RFC 4488") |
| |
| | defineHeader (AnswerMode, "Answer-Mode", Token, "draft-ietf-answermode-01") |
| |
| | defineHeader (PrivAnswerMode, "Priv-Answer-Mode", Token, "draft-ietf-answermode-01") |
| |
| | defineMultiHeader (PAccessNetworkInfo, "P-Access-Network-Info", Token, "RFC 7315") |
| |
| | defineHeader (PChargingVector, "P-Charging-Vector", Token, "RFC 3455") |
| |
| | defineHeader (PChargingFunctionAddresses, "P-Charging-Function-Addresses", Token, "RFC 3455") |
| |
| | defineMultiHeader (Accept, "Accept", Mime, "RFC 3261") |
| |
| | defineHeader (ContentType, "Content-Type", Mime, "RFC 3261") |
| |
| | defineMultiHeader (CallInfo, "Call-Info", GenericUri, "RFC 3261") |
| |
| | defineMultiHeader (AlertInfo, "Alert-Info", GenericUri, "RFC 3261") |
| |
| | defineMultiHeader (ErrorInfo, "Error-Info", GenericUri, "RFC 3261") |
| |
| | defineHeader (IdentityInfo, "Identity-Info", GenericUri, "RFC 4474") |
| |
| | defineMultiHeader (RecordRoute, "Record-Route", NameAddr, "RFC 3261") |
| |
| | defineMultiHeader (Route, "Route", NameAddr, "RFC 3261") |
| |
| | defineMultiHeader (Contact, "Contact", NameAddr, "RFC 3261") |
| |
| | defineHeader (From, "From", NameAddr, "RFC 3261") |
| |
| | defineHeader (To, "To", NameAddr, "RFC 3261") |
| |
| | defineHeader (ReplyTo, "Reply-To", NameAddr, "RFC 3261") |
| |
| | defineHeader (ReferTo, "Refer-To", NameAddr, "RFC 3515") |
| |
| | defineHeader (ReferredBy, "Referred-By", NameAddr, "RFC 3892") |
| |
| | defineMultiHeader (Path, "Path", NameAddr, "RFC 3327") |
| |
| | defineMultiHeader (AcceptContact, "Accept-Contact", NameAddr, "RFC 3841") |
| |
| | defineMultiHeader (RejectContact, "Reject-Contact", NameAddr, "RFC 3841") |
| |
| | defineMultiHeader (PPreferredIdentity, "P-Preferred-Identity", NameAddr, "RFC 3325") |
| |
| | defineMultiHeader (PAssertedIdentity, "P-Asserted-Identity", NameAddr, "RFC 3325") |
| |
| | defineHeader (PCalledPartyId, "P-Called-Party-ID", NameAddr, "RFC 3455") |
| |
| | defineMultiHeader (PAssociatedUri, "P-Associated-URI", NameAddr, "RFC 3455") |
| |
| | defineMultiHeader (ServiceRoute, "Service-Route", NameAddr, "RFC 3608") |
| |
| | defineMultiHeader (RemotePartyId, "Remote-Party-ID", NameAddr, "draft-ietf-sip-privacy-04") |
| |
| | defineMultiHeader (HistoryInfo, "History-Info", NameAddr, "RFC 4244") |
| |
| | defineMultiHeader (Diversion, "Diversion", NameAddr, "RFC 5806") |
| |
| | defineHeader (ContentTransferEncoding, "Content-Transfer-Encoding", StringCategory, "RFC ?") |
| |
| | defineHeader (Organization, "Organization", StringCategory, "RFC 3261") |
| |
| | defineHeader (SecWebSocketKey, "Sec-WebSocket-Key", StringCategory, "RFC 6455") |
| |
| | defineHeader (SecWebSocketKey1, "Sec-WebSocket-Key1", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | defineHeader (SecWebSocketKey2, "Sec-WebSocket-Key2", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | defineHeader (Origin, "Origin", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | defineHeader (Host, "Host", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | defineHeader (SecWebSocketAccept, "Sec-WebSocket-Accept", StringCategory, "RFC 6455") |
| |
| | defineMultiHeader (Cookie, "Cookie", StringCategory, "RFC 6265") |
| |
| | defineHeader (Server, "Server", StringCategory, "RFC 3261") |
| |
| | defineHeader (Subject, "Subject", StringCategory, "RFC 3261") |
| |
| | defineHeader (UserAgent, "User-Agent", StringCategory, "RFC 3261") |
| |
| | defineHeader (Timestamp, "Timestamp", StringCategory, "RFC 3261") |
| |
| | defineHeader (Expires, "Expires", ExpiresCategory, "RFC 3261") |
| |
| | defineHeader (SessionExpires, "Session-Expires", ExpiresCategory, "RFC 4028") |
| |
| | defineHeader (MinSE, "Min-SE", ExpiresCategory, "RFC 4028") |
| |
| | defineHeader (MaxForwards, "Max-Forwards", UInt32Category, "RFC 3261") |
| |
| | defineHeader (ContentLength, "Content-Length", UInt32Category, "RFC 3261") |
| |
| | defineHeader (MinExpires, "Min-Expires", UInt32Category, "RFC 3261") |
| |
| | defineHeader (RSeq, "RSeq", UInt32Category, "RFC 3261") |
| |
| | defineHeader (RetryAfter, "Retry-After", UInt32Category, "RFC 3261") |
| |
| | defineHeader (FlowTimer, "Flow-Timer", UInt32Category, "RFC 5626") |
| |
| | defineHeader (CallID, "Call-ID", CallID, "RFC 3261") |
| |
| | defineHeader (Replaces, "Replaces", CallID, "RFC 3891") |
| |
| | defineHeader (InReplyTo, "In-Reply-To", CallID, "RFC 3261") |
| |
| | defineHeader (Join, "Join", CallId, "RFC 3911") |
| |
| | defineHeader (TargetDialog, "Target-Dialog", CallId, "RFC 4538") |
| |
| | defineHeader (AuthenticationInfo, "Authentication-Info", Auth, "RFC 3261") |
| |
| | defineMultiHeader (Authorization, "Authorization", Auth, "RFC 3261") |
| |
| | defineMultiHeader (ProxyAuthenticate, "Proxy-Authenticate", Auth, "RFC 3261") |
| |
| | defineMultiHeader (ProxyAuthorization, "Proxy-Authorization", Auth, "RFC 3261") |
| |
| | defineMultiHeader (WWWAuthenticate, "Www-Authenticate", Auth, "RFC 3261") |
| |
| | defineHeader (CSeq, "CSeq", CSeqCategory, "RFC 3261") |
| |
| | defineHeader (Date, "Date", DateCategory, "RFC 3261") |
| |
| | defineMultiHeader (Warning, "Warning", WarningCategory, "RFC 3261") |
| |
| | defineMultiHeader (RESIP_DO_NOT_USE, "If you see this things are seriously awry", StringCategory, "NA") |
| |
| | defineMultiHeader (Via, "Via", Via, "RFC 3261") |
| |
| | defineHeader (RAck, "RAck", RAckCategory, "RFC 3262") |
| |
| | defineMultiHeader (PVisitedNetworkID, "P-Visited-Network-ID", TokenOrQuotedStringCategory, "RFC 3455") |
| |
| | defineMultiHeader (UserToUser, "User-to-User", TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17") |
| |
| | defineMultiHeader (Identity, "Identity", IdentityCategory, "RFC 8224") |
| |
| EncodeStream & | operator<< (EncodeStream &, const LazyParser &lp) |
| |
| std::ostream & | operator<< (std::ostream &, const LazyParser &lp) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Message &msg) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Message::Brief &brief) |
| |
| std::ostream & | operator<< (std::ostream &strm, const Message &msg) |
| |
| std::ostream & | operator<< (std::ostream &strm, const Message::Brief &brief) |
| |
| const char * | skipSipLWS (ParseBuffer &pb) |
| |
| MethodTypes | getMethodType (const Data &name) |
| |
| MethodTypes | getMethodType (const char *name, int len) |
| |
| const Data & | getMethodName (MethodTypes t) |
| |
| static int | c2i (unsigned char c) |
| |
| static void | initCharInfoArray () |
| |
| void | specTransition (State state, CharCategory charCategory, TransitionAction action, State nextState) |
| |
| static void | specDefaultTransition (State state, TransitionAction action, State nextState) |
| |
| static void | specHalfLineBreakState (State halfLineBreakState, State afterLineBreakState) |
| |
| static void | specXValueStates (int stateDelta) |
| |
| static void | initStateMachine () |
| |
| void | lookupMsgHeaderFieldInfo (char *fieldName, unsigned int *fieldNameLength, MsgHeaderScanner::TextPropBitMask fieldNameTextPropBitMask, int *fieldKind, bool *isMultiValueAllowed) |
| | defined(RESIP_MSG_HEADER_SCANNER_DEBUG) } {
|
| |
| bool | processMsgHeaderStatusLine (SipMessage *msg, char *lineText, unsigned int lineTextLength, MsgHeaderScanner::TextPropBitMask lineTextPropBitMask) |
| |
| void | processMsgHeaderFieldNameAndValue (SipMessage *msg, int fieldKind, const char *fieldName, unsigned int fieldNameLength, char *valueText, unsigned int valueTextLength, MsgHeaderScanner::TextPropBitMask valueTextPropBitMask) |
| |
| | defineParam (data, "data", ExistsParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (control, "control", ExistsParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (mobility, "mobility", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (description, "description", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (events, "events", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (priority, "priority", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (methods, "methods", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (schemes, "schemes", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (application, "application", ExistsParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (video, "video", ExistsParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (language, "language", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (type, "type", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (isFocus, "isfocus", ExistsParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (actor, "actor", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam2 (text, "text", ExistsOrDataParameter, NameAddr, Token, "RFC 3326/3840") |
| |
| | defineParam (cause, "cause", UInt32Parameter, Token, "RFC3326") |
| |
| | defineParam (extensions, "extensions", QuotedDataParameter, NameAddr, "RFC 3840") |
| |
| | defineParam (Instance, "+sip.instance", QuotedDataParameter, NameAddr, "RFC 5626") |
| |
| | defineParam (regid, "reg-id", UInt32Parameter, NameAddr, "RFC 5626") |
| |
| | defineParam (ob,"ob", ExistsParameter, Uri, "RFC 5626") |
| |
| | defineParam (pubGruu, "pub-gruu", QuotedDataParameter, NameAddr, "RFC 5627") |
| |
| | defineParam (tempGruu, "temp-gruu", QuotedDataParameter, NameAddr, "RFC 5627") |
| |
| | defineParam (gr, "gr", ExistsOrDataParameter, Uri, "RFC 5627") |
| |
| | defineParam (accessType, "access-type", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (algorithm, "algorithm", DataParameter, Auth, "RFC 2617") |
| |
| | defineParam (boundary, "boundary", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (branch, "branch", BranchParameter, Via, "RFC 3261") |
| |
| | defineParam (charset, "charset", DataParameter, Mime, "RFC 2045") |
| |
| | defineParam (cnonce, "cnonce", QuotedDataParameter, Auth, "RFC 2617") |
| |
| | defineParam2 (comp, "comp", DataParameter, Uri, Via, "RFC 3486") |
| |
| | defineParam (dAlg, "d-alg", DataParameter, Token, "RFC 3329") |
| |
| | defineParam (dQop, "d-qop", DataParameter, Token, "RFC 3329") |
| |
| | defineParam (dVer, "d-ver", QuotedDataParameter, Token, "RFC 3329") |
| |
| | defineParam (directory, "directory", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (domain, "domain", QuotedDataParameter, Auth, "RFC 3261") |
| |
| | defineParam2 (duration, "duration", UInt32Parameter, Uri, UInt32Category, "RFC 4240") |
| |
| | defineParam (expiration, "expiration", QuotedDataParameter, Mime, "RFC 2046") |
| |
| | defineParam2 (expires, "expires", UInt32Parameter, NameAddr, Token, "RFC 3261") |
| |
| | defineParam (filename, "filename", DataParameter, Token, "RFC 2183") |
| |
| | defineParam2 (fromTag, "from-tag", DataParameter, Token, CallID, "RFC 4235") |
| |
| | defineParam (handling, "handling", DataParameter, Token, "RFC 3261") |
| |
| | defineParam (id, "id", DataParameter, Token, "RFC 3265") |
| |
| | defineParam (lr, "lr", ExistsParameter, Uri, "RFC 3261") |
| |
| | defineParam2 (maddr, "maddr", DataParameter, Uri, Via, "RFC 3261") |
| |
| | defineParam (method, "method", DataParameter, Uri, "RFC 3261") |
| |
| | defineParam (micalg, "micalg", DataParameter, Mime, "RFC 1847") |
| |
| | defineParam (mode, "mode", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (name, "name", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (nc, "nc", DataParameter, Auth, "RFC 2617") |
| |
| | defineParam (nonce, "nonce", QuotedDataParameter, Auth, "RFC 2617") |
| |
| | defineParam (opaque, "opaque", QuotedDataParameter, Auth, "RFC 2617") |
| |
| | defineParam (permission, "permission", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (protocol, "protocol", QuotedDataParameter, Mime, "RFC 1847") |
| |
| | defineParam2 (purpose, "purpose", DataParameter, GenericUri, TokenOrQuotedStringCategory, "RFC 3261, draft-ietf-cuss-sip-uui-17") |
| |
| | defineParam3 (q, "q", QValueParameter, NameAddr, Token, Mime, "RFC 3261") |
| |
| | defineParam (realm, "realm", QuotedDataParameter, Auth, "RFC 2617") |
| |
| | defineParam2 (reason, "reason", DataParameter, Token, NameAddr, "RFC 3265, 5806") |
| |
| | defineParam (received, "received", ReceivedParameter, Via, "RFC 3261") |
| |
| | defineParam (require, "require", ExistsParameter, Token, "RFC 5373") |
| |
| | defineParam (response, "response", QuotedDataParameter, Auth, "RFC 3261") |
| |
| | defineParam (retryAfter, "retry-after", UInt32Parameter, Token, "RFC 3265") |
| |
| | defineParam (rinstance, "rinstance", DataParameter, Uri, "proprietary (resip)") |
| |
| | defineParam (rport, "rport", RportParameter, Via, "RFC 3581") |
| |
| | defineParam (server, "server", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (site, "site", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (size, "size", DataParameter, Mime, "RFC 2046") |
| |
| | defineParam (smimeType, "smime-type", DataParameter, Mime, "RFC 2633") |
| |
| | defineParam (stale, "stale", DataParameter, Auth, "RFC 2617") |
| |
| | defineParam (tag, "tag", DataParameter, NameAddr, "RFC 3261") |
| |
| | defineParam2 (toTag, "to-tag", DataParameter, Token, CallID, "RFC 4235") |
| |
| | defineParam (transport, "transport", DataParameter, Uri, "RFC 3261") |
| |
| | defineParam2 (ttl, "ttl", UInt32Parameter, Uri, Via, "RFC 3261") |
| |
| | defineParam (uri, "uri", QuotedDataParameter, Auth, "RFC 3261") |
| |
| | defineParam (user, "user", DataParameter, Uri, "RFC 3261, 4967") |
| |
| | defineParam2 (extension, "ext", DataParameter, Uri, Token, "RFC 3966") |
| |
| | defineParam (username, "username", QuotedDataParameter, Auth, "RFC 3261") |
| |
| | defineParam (earlyOnly, "early-only", ExistsParameter, CallID, "RFC 3891") |
| |
| | defineParam (refresher, "refresher", DataParameter, ExpiresCategory, "RFC 4028") |
| |
| | defineParam (profileType, "profile-type", DataParameter, Token, "RFC 6080") |
| |
| | defineParam (vendor, "vendor", QuotedDataParameter, Token, "RFC 6080") |
| |
| | defineParam (model, "model", QuotedDataParameter, Token, "RFC 6080") |
| |
| | defineParam (version, "version", QuotedDataParameter, Token, "RFC 6080") |
| |
| | defineParam (effectiveBy, "effective-by", UInt32Parameter, Token, "RFC 6080") |
| |
| | defineParam (document, "document", DataParameter, Token, "draft-ietf-sipping-config-framework-07 (removed in 08)") |
| |
| | defineParam (appId, "app-id", DataParameter, Token, "draft-ietf-sipping-config-framework-05 (renamed to auid in 06, which was then removed in 08)") |
| |
| | defineParam (networkUser, "network-user", DataParameter, Token, "draft-ietf-sipping-config-framework-11 (removed in 12)") |
| |
| | defineParam (url, "url", QuotedDataParameter, Mime, "RFC 4483") |
| |
| | defineParam2 (sigcompId, "sigcomp-id", QuotedDataParameter, Uri, Via, "RFC 5049") |
| |
| | defineParam (qop,"qop", DataParameter, Auth, "RFC 3261") |
| |
| | defineParam (index, "index", DataParameter, NameAddr, "RFC 4244") |
| |
| | defineParam (rc, "rc", DataParameter, NameAddr, "RFC 4244-bis") |
| |
| | defineParam (mp, "mp", DataParameter, NameAddr, "RFC 4244-bis") |
| |
| | defineParam (np, "np", DataParameter, NameAddr, "RFC 4244-bis") |
| |
| | defineParam (utranCellId3gpp, "utran-cell-id-3gpp", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (cgi3gpp, "cgi-3gpp", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (ccf, "ccf", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (ecf, "ecf", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (icidValue, "icid-value", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (icidGeneratedAt, "icid-generated-at", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (origIoi, "orig-ioi", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (termIoi, "term-ioi", DataParameter, Token, "RFC 3455") |
| |
| | defineParam (content, "content", DataParameter, TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17") |
| |
| | defineParam (encoding, "encoding", DataParameter, TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17") |
| |
| | defineParam (info, "info", UriParameter, IdentityCategory, "RFC 8224") |
| |
| | defineParam (alg, "alg", DataParameter, GenericUri, "RFC 8224") |
| |
| | defineParam (ppt, "ppt", DataParameter, GenericUri, "RFC 8224") |
| |
| | defineParam (counter, "counter", UInt32Parameter, NameAddr, "RFC 5806") |
| |
| | defineParam (limit, "limit", UInt32Parameter, NameAddr, "RFC 5806") |
| |
| | defineParam (privacy, "privacy", DataParameter, NameAddr, "RFC 5806") |
| |
| | defineParam (screen, "screen", DataParameter, NameAddr, "RFC 5806") |
| |
| | defineParam (qopOptions,"qop", DataParameter, Auth, "RFC 3261") |
| |
| | defineParam (addTransport, "addTransport", ExistsParameter, Uri, "RESIP INTERNAL") |
| |
| | defineParam (wsSrcIp, "ws-src-ip", DataParameter, Uri, "RESIP INTERNAL (WebSocket)") |
| |
| | defineParam (wsSrcPort, "ws-src-port", UInt32Parameter, Uri, "RESIP INTERNAL (WebSocket)") |
| |
| EncodeStream & | operator<< (EncodeStream &, const ParserCategory &category) |
| |
| template<class T > |
| EncodeStream & | insert (EncodeStream &s, const resip::ParserContainer< T > &c) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Pidf::Tuple &tuple) |
| |
| EncodeStream & | operator<< (EncodeStream &stream, const QValue &qvalue) |
| | calls encode and returns "q=3" or equivalent ostream
|
| |
| static void | foo () |
| |
| bool | operator== (const SdpContents::Session::Codec &lhs, const SdpContents::Session::Codec &rhs) |
| |
| bool | operator!= (const SdpContents::Session::Codec &lhs, const SdpContents::Session::Codec &rhs) |
| |
| EncodeStream & | operator<< (EncodeStream &str, const SdpContents::Session::Codec &codec) |
| |
| void | skipEol (ParseBuffer &pb) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const SecurityAttributes &sa) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const SipStack &stack) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const StatisticsMessage::Payload &stats) |
| |
| template<class T > |
| std::ostream & | operator<< (std::ostream &str, const TimerQueue< T > &tq) |
| |
| template<class T > |
| EncodeStream & | operator<< (EncodeStream &str, const TimerQueue< T > &tq) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const TransactionState &state) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const TransactionUser &tu) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Transport &rhs) |
| |
| EncodeStream & | operator<< (EncodeStream &ostrm, const TransportSelector::TlsTransportKey &tlsTransportKey) |
| |
| EncodeStream & | operator<< (EncodeStream &ostrm, const Tuple &tuple) |
| |
| EncodeStream & | operator<< (EncodeStream &ostrm, const AddressMask &addressMask) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const MessageId &id) |
| |
| std::ostream & | operator<< (std::ostream &strm, const ChallengeInfo &msg) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Dialog &dialog) |
| |
| EncodeStream & | operator<< (EncodeStream &, const DialogId &id) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const DialogSet &ds) |
| |
| EncodeStream & | operator<< (EncodeStream &, const DialogSetId &) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const Handled &usage) |
| |
| const Data & | getSubscriptionStateString (SubscriptionState state) |
| |
| const Data & | getTerminateReasonString (TerminateReason state) |
| |
| std::ostream & | operator<< (std::ostream &strm, const TlsPeerIdentityInfoMessage &msg) |
| |
| EncodeStream & | operator<< (EncodeStream &strm, const UserAuthInfo &msg) |
| |
| EncodeStream & | operator<< (EncodeStream &, const UserProfile &profile) |
| |
| EncodeStream & | operator<< (EncodeStream &, const UserProfile::DigestCredential &cred) |
| |