reSIProcate
SIP stack, Dialog Usage Manager and related libraries
Loading...
Searching...
No Matches
HeaderTypes.hxx
Go to the documentation of this file.
1#if !defined(RESIP_HEADERTYPES_HXX)
2#define RESIP_HEADERTYPES_HXX
3
4#include "rutil/Data.hxx"
5
6//****************************************************************************
7//
8// !dlb! until automated, must ensure that this set is consistent with
9//
10// ************ PLEASE RUN testParserCategories AFTER CHANGING ***************
11//
12// HeaderTypes.hxx
13// Headers.hxx
14// HeaderHash.gperf
15// Headers.cxx
16// SipMessage.hxx
17// SipMessage.cxx
18//
19//****************************************************************************
20
21// eventually use these macros to automate Headers.hxx, Headers.cxx+gperf
22#define UNUSED_defineHeader(_enum, _name, _type, _rfc) SAVE##_enum, _enum = UNKNOWN, RESET##enum = SAVE##_enum-1
23#define UNUSED_defineMultiHeader(_enum, _name, _type, _rfc) SAVE##_enum, _enum = UNKNOWN, RESET##enum = SAVE##_enum-1
24#define defineHeader(_enum, _name, _type, _rfc) _enum
25#define defineMultiHeader(_enum, _name, _type, _rfc) _enum
26
27namespace resip
28{
29
39{
40 public:
41 enum Type
42 {
43 UNKNOWN = -1,
44 defineMultiHeader(Via, "Via", Via, "RFC 3261"), // rjs says must be first
45 defineHeader(MaxForwards, "Max-Forwards", UInt32Category, "RFC 3261"),
46 defineMultiHeader(Route, "Route", NameAddr, "RFC 3261"),
47 defineMultiHeader(RecordRoute, "Record-Route", NameAddr, "RFC 3261"),
48 defineMultiHeader(Path, "Path", NameAddr, "RFC 3327"),
49 defineMultiHeader(ServiceRoute, "Service-Route", NameAddr, "RFC 3608"),
50 defineMultiHeader(ProxyRequire, "Proxy-Require", Token, "RFC 3261"),
51 defineMultiHeader(ProxyAuthenticate, "Proxy-Authenticate", Auth, "RFC 3261"),
52 defineHeader(Identity, "Identity", StringCategory, "RFC 4474"),
53 defineHeader(IdentityInfo, "Identity-Info", GenericUri, "RFC 4474"),
54 defineMultiHeader(Require, "Require", Token, "RFC 3261"),
55 defineMultiHeader(Contact, "Contact", NameAddr, "RFC 3261"),
56
57 defineHeader(To, "To", NameAddr, "RFC 3261"),
58 defineHeader(From, "From", NameAddr, "RFC 3261"),
59 defineHeader(CallID, "Call-ID", CallId, "RFC 3261"),
60 defineHeader(CSeq, "CSeq", CSeqCategory, "RFC 3261"),
61 defineHeader(Subject, "Subject", StringCategory, "RFC 3261"),
62 defineHeader(Expires, "Expires", ExpiresCategory, "RFC 3261"),
63 defineHeader(SessionExpires, "Session-Expires", ExpiresCategory, "RFC 4028"),
64 defineHeader(MinSE, "Min-SE", ExpiresCategory, "RFC 4028"),
65 defineMultiHeader(Accept, "Accept", Mime, "RFC 3261"),
66 defineMultiHeader(AcceptEncoding, "Accept-Encoding", Token, "RFC 3261"),
67 defineMultiHeader(AcceptLanguage, "Accept-Language", Token, "RFC 3261"),
68 defineMultiHeader(AlertInfo, "Alert-Info", GenericUri, "RFC 3261"),
69 defineMultiHeader(Allow, "Allow", Token, "RFC 3261"),
70 defineHeader(AuthenticationInfo, "Authentication-Info", Auth, "RFC 3261"),
71 defineMultiHeader(CallInfo, "Call-Info", GenericUri, "RFC 3261"),
72 defineHeader(ContentDisposition, "Content-Disposition", Token, "RFC ?"),
73 defineHeader(ContentEncoding, "Content-Encoding", Token, "RFC ?"),
74 defineHeader(ContentId, "Content-ID", Token, "RFC 2045"),
75 defineMultiHeader(ContentLanguage, "Content-Language", Token, "RFC ?"),
76// i really think that Content-Transfer-Encoding should be a Token !rwm
77 defineHeader(ContentTransferEncoding, "Content-Transfer-Encoding", StringCategory, "RFC ?"), // !dlb! defineMultiHeader
78 defineHeader(ContentType, "Content-Type", Mime, "RFC 3261"),
79 defineHeader(Date, "Date", DateCategory, "RFC 3261"),
80 defineMultiHeader(ErrorInfo, "Error-Info", GenericUri, "RFC 3261"),
81 defineHeader(InReplyTo, "In-Reply-To", CallId, "RFC 3261"),
82 defineHeader(MinExpires, "Min-Expires", UInt32Category, "RFC 3261"),
83 defineHeader(MIMEVersion, "MIME-Version", Token, "RFC 3261"),
84 defineHeader(Organization, "Organization", StringCategory, "RFC 3261"),
85 defineHeader(SecWebSocketKey, "Sec-WebSocket-Key", StringCategory, "RFC 6455"),
86 defineHeader(SecWebSocketKey1, "Sec-WebSocket-Key1", StringCategory, "draft-hixie- thewebsocketprotocol-76"),
87 defineHeader(SecWebSocketKey2, "Sec-WebSocket-Key2", StringCategory, "draft-hixie- thewebsocketprotocol-76"),
88 defineHeader(Origin, "Origin", StringCategory, "draft-hixie- thewebsocketprotocol-76"),
89 defineHeader(Host, "Host", StringCategory, "draft-hixie- thewebsocketprotocol-76"),
90 defineHeader(SecWebSocketAccept, "Sec-WebSocket-Accept", StringCategory, "RFC 6455"),
91 defineMultiHeader(Cookie, "Cookie", StringCategory, "RFC 6265"),
92 defineHeader(Priority, "Priority", Token, "RFC 3261"),
93 defineMultiHeader(ProxyAuthorization, "Proxy-Authorization", Auth, "RFC 3261"),
94 defineHeader(ReplyTo, "Reply-To", NameAddr, "RFC 3261"),
95 defineHeader(RetryAfter, "Retry-After", UInt32Category, "RFC 3261"),
96 defineHeader(FlowTimer, "Flow-Timer", UInt32Category, "RFC 5626"),
97 defineHeader(Server, "Server", StringCategory, "RFC 3261"),
98 defineHeader(SIPETag, "SIP-ETag", Token, "RFC 3903"),
99 defineHeader(SIPIfMatch, "SIP-If-Match", Token, "RFC 3903"),
100 defineMultiHeader(Supported, "Supported", Token, "RFC 3261"),
101 defineHeader(Timestamp, "Timestamp", StringCategory, "RFC 3261"),
102 defineMultiHeader(Unsupported, "Unsupported", Token, "RFC 3261"),
103 defineHeader(UserAgent, "User-Agent", StringCategory, "RFC 3261"),
104 defineMultiHeader(Warning, "Warning", WarningCategory, "RFC 3261"),
105 defineMultiHeader(WWWAuthenticate, "WWW-Authenticate", Auth, "RFC 3261"),
106 defineHeader(SubscriptionState, "Subscription-State", Token, "RFC 3265"),
107 defineHeader(ReferTo, "Refer-To", NameAddr, "RFC 3515"),
108 defineHeader(ReferredBy, "Referred-By", NameAddr, "RFC 3892"),
109 defineMultiHeader(Authorization, "Authorization", Auth, "RFC 3261"),
110 defineHeader(Replaces, "Replaces", CallId, "RFC 3891"),
111 defineHeader(Event, "Event", Token, "RFC 3265"),
112 defineMultiHeader(AllowEvents, "Allow-Events", Token, "RFC 3265"),
113 defineMultiHeader(SecurityClient, "Security-Client", Token, "RFC 3329"),
114 defineMultiHeader(SecurityServer, "Security-Server", Token, "RFC 3329"),
115 defineMultiHeader(SecurityVerify, "Security-Verify", Token, "RFC 3329"),
116 defineHeader(RSeq, "RSeq", UInt32Category, "RFC 3262"),
117 defineHeader(RAck, "RAck", RAckCategory, "RFC 3262"),
118
119 defineMultiHeader(Reason, "Reason", Token, "RFC 3326"),
120 defineMultiHeader(Privacy, "Privacy", PrivacyCategory, "RFC 3323"),
121 defineMultiHeader(RequestDisposition, "Request-Disposition", Token, "RFC 3841"),
122 defineMultiHeader(PMediaAuthorization, "P-Media-Authorization", Token, "RFC 3313"),
123 defineHeader(Join, "Join", CallId, "RFC 3911"),
124 defineHeader(TargetDialog, "Target-Dialog", CallId, "RFC 4538"),
125 defineMultiHeader(PAssertedIdentity, "P-Asserted-Identity", NameAddr, "RFC 3325"),
126 defineMultiHeader(PPreferredIdentity, "P-Preferred-Identity", NameAddr, "RFC 3325"),
127 defineMultiHeader(AcceptContact, "Accept-Contact", NameAddr, "RFC 3841"),
128 defineMultiHeader(RejectContact, "Reject-Contact", NameAddr, "RFC 3841"),
129 defineHeader(PCalledPartyId, "P-Called-Party-ID", NameAddr, "RFC 3455"),
130 defineMultiHeader(PAssociatedUri, "P-Associated-URI", NameAddr, "RFC 3455"),
131
132 defineHeader(ContentLength, "Content-Length", UInt32Category, "RFC 3261"),
133 defineHeader(ReferSub, "Refer-Sub", Token, "RFC 4488"),
134 defineHeader(AnswerMode, "Answer-Mode", Token, "RFC 5373"),
135 defineHeader(PrivAnswerMode, "Priv-Answer-Mode", Token, "RFC 5373"),
136 defineMultiHeader(RemotePartyId, "Remote-Party-ID", NameAddr, "draft-ietf-sip-privacy-04"), // ?bwc? Not in 3323, should we keep?
137 defineMultiHeader(HistoryInfo, "History-Info", NameAddr, "RFC 4244"),
138 defineMultiHeader(Diversion, "Diversion", NameAddr, "RFC 5806"),
139
140 defineMultiHeader(PAccessNetworkInfo, "P-Access-Network-Info", Token, "RFC 7315"), // section 5.4.
141 defineHeader(PChargingVector, "P-Charging-Vector", Token, "RFC 3455"),
142 defineHeader(PChargingFunctionAddresses, "P-Charging-Function-Addresses", Token, "RFC 3455"),
143 defineMultiHeader(PVisitedNetworkID, "P-Visited-Network-ID", TokenOrQuotedStringCategory, "RFC 3455"),
144
145 defineMultiHeader(UserToUser, "User-to-User", TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17"),
146
147 defineMultiHeader(RESIP_DO_NOT_USE, "ShouldNotSeeThis", StringCategory, "N/A"),
149 NONE
150 };
151
152 // get enum from header name
153 static Type getType(const char* name, size_t len);
154 static bool isCommaTokenizing(Type type);
155 static bool isCommaEncoding(Type type);
156 static const Data& getHeaderName(int);
157 static bool isMulti(Type type);
158
159 // treat as private
163 static bool Multi[MAX_HEADERS+1];
164};
165
166}
167
168#undef UNUSED_defineHeader
169#undef UNUSED_defineMultiHeader
170#undef defineHeader
171#undef defineMultiHeader
172
173#endif
174
175/* ====================================================================
176 * The Vovida Software License, Version 1.0
177 *
178 * Copyright (c) 2026 SIP Spectrum, Inc. https://www.sipspectrum.com
179 * Copyright (c) 2000 Vovida Networks, Inc. All rights reserved.
180 *
181 * Redistribution and use in source and binary forms, with or without
182 * modification, are permitted provided that the following conditions
183 * are met:
184 *
185 * 1. Redistributions of source code must retain the above copyright
186 * notice, this list of conditions and the following disclaimer.
187 *
188 * 2. Redistributions in binary form must reproduce the above copyright
189 * notice, this list of conditions and the following disclaimer in
190 * the documentation and/or other materials provided with the
191 * distribution.
192 *
193 * 3. The names "VOCAL", "Vovida Open Communication Application Library",
194 * and "Vovida Open Communication Application Library (VOCAL)" must
195 * not be used to endorse or promote products derived from this
196 * software without prior written permission. For written
197 * permission, please contact vocal@vovida.org.
198 *
199 * 4. Products derived from this software may not be called "VOCAL", nor
200 * may "VOCAL" appear in their name, without prior written
201 * permission of Vovida Networks, Inc.
202 *
203 * THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED
204 * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
205 * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND
206 * NON-INFRINGEMENT ARE DISCLAIMED. IN NO EVENT SHALL VOVIDA
207 * NETWORKS, INC. OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT DAMAGES
208 * IN EXCESS OF $1,000, NOR FOR ANY INDIRECT, INCIDENTAL, SPECIAL,
209 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
210 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
211 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
212 * OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
213 * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
214 * USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
215 * DAMAGE.
216 *
217 * ====================================================================
218 *
219 * This software consists of voluntary contributions made by Vovida
220 * Networks, Inc. and many individuals on behalf of Vovida Networks,
221 * Inc. For more information on Vovida Networks, Inc., please see
222 * <http://www.vovida.org/>.
223 *
224 */
Represents the "credentials" and "challenge" elements in the SIP grammar.
Definition Auth.hxx:18
Represents a CSeq header field value (this doesn't have an official name in the RFC 3261 grammar).
Represents the "callid" element in the SIP grammar.
Definition CallId.hxx:18
An alternative to std::string, encapsulates an arbitrary buffer of bytes.
Definition Data.hxx:90
Represents the "SIP-date" element in the RFC 3261 grammar.
Represents the header field value for an Expires-type header.
Represents the "absoluteURI" element in the RFC 3261 grammar.
Maps from header name to derived ParserCategory.
static Type getType(const char *name, size_t len)
Definition Headers.cxx:351
static bool Multi[MAX_HEADERS+1]
static const Data & getHeaderName(int)
Definition Headers.cxx:37
static bool isCommaTokenizing(Type type)
Definition Headers.cxx:25
static bool isMulti(Type type)
Definition Headers.cxx:50
static bool CommaEncoding[MAX_HEADERS+1]
static bool isCommaEncoding(Type type)
Definition Headers.cxx:31
static bool CommaTokenizing[MAX_HEADERS+1]
static Data HeaderNames[MAX_HEADERS+1]
Represents the "media-type" element in the RFC 3261 grammar.
Definition Mime.hxx:20
Represents the "name-addr" and the "addr-spec" elements in the RFC 3261 grammar.
Definition NameAddr.hxx:19
Represents the "token" element in the RFC 3261 grammar.
Represents the RAck header field value defined in the RFC 3262 grammar.
Represents the "header-value" element in the RFC 3261 grammar (ie, an unknown header field value).
Generically represents a token whose value can be wrapped and encoded using double quotes.
Represents the "token" element in the RFC 3261 grammar.
Definition Token.hxx:18
Represents a numeric-with-comment header field value.
Represents the "via-parm" element in the RFC 3261 grammar.
Definition Via.hxx:18
Represents the "warning-value" element in the RFC 3261 grammar.
dcm! – add UnusedChecking(_enum) below;