reSIProcate
SIP stack, Dialog Usage Manager and related libraries
Loading...
Searching...
No Matches
Headers.cxx File Reference
#include "rutil/Data.hxx"
#include "resip/stack/Headers.hxx"
#include "resip/stack/Symbols.hxx"
#include "resip/stack/SipMessage.hxx"
#include "resip/stack/HeaderHash.hxx"
#include <iostream>

Go to the source code of this file.

Macros

#define defineHeader(_enum, _name, _type, _reference)
 
#define defineMultiHeader(_enum, _name, _type, _reference)
 

Typedefs

typedef ParserContainer< Mime > Mimes
 
typedef ParserContainer< GenericUri > GenericUris
 
typedef ParserContainer< NameAddr > NameAddrs
 
typedef ParserContainer< StringCategory > StringCategories
 

Functions

 defineHeader (ContentDisposition, "Content-Disposition", Token, "RFC 3261")
 
 defineHeader (ContentEncoding, "Content-Encoding", Token, "RFC 3261")
 
 defineHeader (ContentTransferEncoding, "Content-Transfer-Encoding", StringCategory, "RFC ?")
 
 defineHeader (MIMEVersion, "MIME-Version", Token, "RFC 3261")
 
 defineHeader (Priority, "Priority", Token, "RFC 3261")
 
 defineHeader (Event, "Event", Token, "RFC 3265")
 
 defineHeader (SubscriptionState, "Subscription-State", Token, "RFC 3265")
 
 defineHeader (SIPETag, "SIP-ETag", Token, "RFC 3903")
 
 defineHeader (SIPIfMatch, "SIP-If-Match", Token, "RFC 3903")
 
 defineHeader (ContentId, "Content-ID", Token, "RFC 2045")
 
 defineMultiHeader (AllowEvents, "Allow-Events", Token, "RFC 3265")
 
 defineMultiHeader (AcceptEncoding, "Accept-Encoding", Token, "RFC 3261")
 
 defineMultiHeader (AcceptLanguage, "Accept-Language", Token, "RFC 3261")
 
 defineMultiHeader (Allow, "Allow", Token, "RFC 3261")
 
 defineMultiHeader (ContentLanguage, "Content-Language", Token, "RFC 3261")
 
 defineMultiHeader (ProxyRequire, "Proxy-Require", Token, "RFC 3261")
 
 defineMultiHeader (Require, "Require", Token, "RFC 3261")
 
 defineMultiHeader (Supported, "Supported", Token, "RFC 3261")
 
 defineMultiHeader (Unsupported, "Unsupported", Token, "RFC 3261")
 
 defineMultiHeader (SecurityClient, "Security-Client", Token, "RFC 3329")
 
 defineMultiHeader (SecurityServer, "Security-Server", Token, "RFC 3329")
 
 defineMultiHeader (SecurityVerify, "Security-Verify", Token, "RFC 3329")
 
 defineMultiHeader (RequestDisposition, "Request-Disposition", Token, "RFC 3841")
 
 defineMultiHeader (Reason, "Reason", Token, "RFC 3326")
 
 defineMultiHeader (Privacy, "Privacy", PrivacyCategory, "RFC 3323")
 
 defineMultiHeader (PMediaAuthorization, "P-Media-Authorization", Token, "RFC 3313")
 
 defineHeader (ReferSub, "Refer-Sub", Token, "RFC 4488")
 
 defineHeader (AnswerMode, "Answer-Mode", Token, "draft-ietf-answermode-01")
 
 defineHeader (PrivAnswerMode, "Priv-Answer-Mode", Token, "draft-ietf-answermode-01")
 
 defineMultiHeader (PAccessNetworkInfo, "P-Access-Network-Info", Token, "RFC 7315")
 
 defineHeader (PChargingVector, "P-Charging-Vector", Token, "RFC 3455")
 
 defineHeader (PChargingFunctionAddresses, "P-Charging-Function-Addresses", Token, "RFC 3455")
 
 defineMultiHeader (Accept, "Accept", Mime, "RFC 3261")
 
 defineHeader (ContentType, "Content-Type", Mime, "RFC 3261")
 
 defineHeader (IdentityInfo, "Identity-Info", GenericUri, "RFC 4474")
 
 defineMultiHeader (CallInfo, "Call-Info", GenericUri, "RFC 3261")
 
 defineMultiHeader (AlertInfo, "Alert-Info", GenericUri, "RFC 3261")
 
 defineMultiHeader (ErrorInfo, "Error-Info", GenericUri, "RFC 3261")
 
 defineMultiHeader (RecordRoute, "Record-Route", NameAddr, "RFC 3261")
 
 defineMultiHeader (Route, "Route", NameAddr, "RFC 3261")
 
 defineMultiHeader (Contact, "Contact", NameAddr, "RFC 3261")
 
 defineHeader (From, "From", NameAddr, "RFC 3261")
 
 defineHeader (To, "To", NameAddr, "RFC 3261")
 
 defineHeader (ReplyTo, "Reply-To", NameAddr, "RFC 3261")
 
 defineHeader (ReferTo, "Refer-To", NameAddr, "RFC 3515")
 
 defineHeader (ReferredBy, "Referred-By", NameAddr, "RFC 3892")
 
 defineMultiHeader (Path, "Path", NameAddr, "RFC 3327")
 
 defineMultiHeader (AcceptContact, "Accept-Contact", NameAddr, "RFC 3841")
 
 defineMultiHeader (RejectContact, "Reject-Contact", NameAddr, "RFC 3841")
 
 defineMultiHeader (PPreferredIdentity, "P-Preferred-Identity", NameAddr, "RFC 3325")
 
 defineMultiHeader (PAssertedIdentity, "P-Asserted-Identity", NameAddr, "RFC 3325")
 
 defineHeader (PCalledPartyId, "P-Called-Party-ID", NameAddr, "RFC 3455")
 
 defineMultiHeader (PAssociatedUri, "P-Associated-URI", NameAddr, "RFC 3455")
 
 defineMultiHeader (ServiceRoute, "Service-Route", NameAddr, "RFC 3608")
 
 defineMultiHeader (RemotePartyId, "Remote-Party-ID", NameAddr, "draft-ietf-sip-privacy-04")
 
 defineMultiHeader (HistoryInfo, "History-Info", NameAddr, "RFC 4244")
 
 defineMultiHeader (Diversion, "Diversion", NameAddr, "RFC 5806")
 
 defineHeader (Organization, "Organization", StringCategory, "RFC 3261")
 
 defineHeader (SecWebSocketKey, "Sec-WebSocket-Key", StringCategory, "RFC 6455")
 
 defineHeader (SecWebSocketKey1, "Sec-WebSocket-Key1", StringCategory, "draft-hixie- thewebsocketprotocol-76")
 
 defineHeader (SecWebSocketKey2, "Sec-WebSocket-Key2", StringCategory, "draft-hixie- thewebsocketprotocol-76")
 
 defineHeader (Origin, "Origin", StringCategory, "draft-hixie- thewebsocketprotocol-76")
 
 defineHeader (Host, "Host", StringCategory, "draft-hixie- thewebsocketprotocol-76")
 
 defineHeader (SecWebSocketAccept, "Sec-WebSocket-Accept", StringCategory, "RFC 6455")
 
 defineMultiHeader (Cookie, "Cookie", StringCategory, "RFC 6265")
 
 defineHeader (Server, "Server", StringCategory, "RFC 3261")
 
 defineHeader (Subject, "Subject", StringCategory, "RFC 3261")
 
 defineHeader (UserAgent, "User-Agent", StringCategory, "RFC 3261")
 
 defineHeader (Timestamp, "Timestamp", StringCategory, "RFC 3261")
 
 defineHeader (ContentLength, "Content-Length", UInt32Category, "RFC 3261")
 
 defineHeader (MaxForwards, "Max-Forwards", UInt32Category, "RFC 3261")
 
 defineHeader (MinExpires, "Min-Expires", UInt32Category, "RFC 3261")
 
 defineHeader (RSeq, "RSeq", UInt32Category, "RFC 3262")
 
 defineHeader (RetryAfter, "Retry-After", UInt32Category, "RFC 3261")
 
 defineHeader (FlowTimer, "Flow-Timer", UInt32Category, "RFC 5626")
 
 defineHeader (Expires, "Expires", ExpiresCategory, "RFC 3261")
 
 defineHeader (SessionExpires, "Session-Expires", ExpiresCategory, "RFC 4028")
 
 defineHeader (MinSE, "Min-SE", ExpiresCategory, "RFC 4028")
 
 defineHeader (CallID, "Call-ID", CallId, "RFC 3261")
 
 defineHeader (Replaces, "Replaces", CallId, "RFC 3891")
 
 defineHeader (InReplyTo, "In-Reply-To", CallId, "RFC 3261")
 
 defineHeader (Join, "Join", CallId, "RFC 3911")
 
 defineHeader (TargetDialog, "Target-Dialog", CallId, "RFC 4538")
 
 defineHeader (AuthenticationInfo, "Authentication-Info", Auth, "RFC 3261")
 
 defineMultiHeader (Authorization, "Authorization", Auth, "RFC 3261")
 
 defineMultiHeader (ProxyAuthenticate, "Proxy-Authenticate", Auth, "RFC 3261")
 
 defineMultiHeader (ProxyAuthorization, "Proxy-Authorization", Auth, "RFC 3261")
 
 defineMultiHeader (WWWAuthenticate, "WWW-Authenticate", Auth, "RFC 3261")
 
 defineHeader (CSeq, "CSeq", CSeqCategory, "RFC 3261")
 
 defineHeader (Date, "Date", DateCategory, "RFC 3261")
 
 defineMultiHeader (Warning, "Warning", WarningCategory, "RFC 3261")
 
 defineHeader (RAck, "RAck", RAckCategory, "RFC 3262")
 
 defineMultiHeader (Via, "Via", Via, "RFC 3261")
 
 defineMultiHeader (PVisitedNetworkID, "P-Visited-Network-ID", TokenOrQuotedStringCategory, "RFC 3455")
 
 defineMultiHeader (UserToUser, "User-to-User", TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17")
 
 defineMultiHeader (Identity, "Identity", IdentityCategory, "RFC 8224")
 

Macro Definition Documentation

◆ defineHeader

#define defineHeader (   _enum,
  _name,
  _type,
  _reference 
)

Definition at line 55 of file Headers.cxx.

◆ defineMultiHeader

#define defineMultiHeader (   _enum,
  _name,
  _type,
  _reference 
)

Definition at line 90 of file Headers.cxx.

Typedef Documentation

◆ GenericUris

◆ Mimes

Definition at line 177 of file Headers.cxx.

◆ NameAddrs

Definition at line 195 of file Headers.cxx.

◆ StringCategories

Function Documentation

◆ defineHeader() [1/52]

defineHeader ( AnswerMode  ,
"Answer-Mode"  ,
Token  ,
"draft-ietf-answermode-01"   
)

◆ defineHeader() [2/52]

defineHeader ( AuthenticationInfo  ,
"Authentication-Info"  ,
Auth  ,
"RFC 3261"   
)

◆ defineHeader() [3/52]

defineHeader ( CallID  ,
"Call-ID"  ,
CallId  ,
"RFC 3261"   
)

◆ defineHeader() [4/52]

defineHeader ( ContentDisposition  ,
"Content-Disposition"  ,
Token  ,
"RFC 3261"   
)

◆ defineHeader() [5/52]

defineHeader ( ContentEncoding  ,
"Content-Encoding"  ,
Token  ,
"RFC 3261"   
)

◆ defineHeader() [6/52]

defineHeader ( ContentId  ,
"Content-ID"  ,
Token  ,
"RFC 2045"   
)

◆ defineHeader() [7/52]

defineHeader ( ContentLength  ,
"Content-Length"  ,
UInt32Category  ,
"RFC 3261"   
)

◆ defineHeader() [8/52]

defineHeader ( ContentTransferEncoding  ,
"Content-Transfer-Encoding"  ,
StringCategory  ,
"RFC ?"   
)

◆ defineHeader() [9/52]

defineHeader ( ContentType  ,
"Content-Type"  ,
Mime  ,
"RFC 3261"   
)

◆ defineHeader() [10/52]

defineHeader ( CSeq  ,
"CSeq"  ,
CSeqCategory  ,
"RFC 3261"   
)

◆ defineHeader() [11/52]

defineHeader ( Date  ,
"Date"  ,
DateCategory  ,
"RFC 3261"   
)

◆ defineHeader() [12/52]

defineHeader ( Event  ,
"Event"  ,
Token  ,
"RFC 3265"   
)

◆ defineHeader() [13/52]

defineHeader ( Expires  ,
"Expires"  ,
ExpiresCategory  ,
"RFC 3261"   
)

◆ defineHeader() [14/52]

defineHeader ( FlowTimer  ,
"Flow-Timer"  ,
UInt32Category  ,
"RFC 5626"   
)

◆ defineHeader() [15/52]

defineHeader ( From  ,
"From"  ,
NameAddr  ,
"RFC 3261"   
)

◆ defineHeader() [16/52]

defineHeader ( Host  ,
"Host"  ,
StringCategory  ,
"draft-hixie- thewebsocketprotocol-76"   
)

◆ defineHeader() [17/52]

defineHeader ( IdentityInfo  ,
"Identity-Info"  ,
GenericUri  ,
"RFC 4474"   
)

◆ defineHeader() [18/52]

defineHeader ( InReplyTo  ,
"In-Reply-To"  ,
CallId  ,
"RFC 3261"   
)

◆ defineHeader() [19/52]

defineHeader ( Join  ,
"Join"  ,
CallId  ,
"RFC 3911"   
)

◆ defineHeader() [20/52]

defineHeader ( MaxForwards  ,
"Max-Forwards"  ,
UInt32Category  ,
"RFC 3261"   
)

◆ defineHeader() [21/52]

defineHeader ( MIMEVersion  ,
"MIME-Version"  ,
Token  ,
"RFC 3261"   
)

◆ defineHeader() [22/52]

defineHeader ( MinExpires  ,
"Min-Expires"  ,
UInt32Category  ,
"RFC 3261"   
)

◆ defineHeader() [23/52]

defineHeader ( MinSE  ,
"Min-SE"  ,
ExpiresCategory  ,
"RFC 4028"   
)

◆ defineHeader() [24/52]

defineHeader ( Organization  ,
"Organization"  ,
StringCategory  ,
"RFC 3261"   
)

◆ defineHeader() [25/52]

defineHeader ( Origin  ,
"Origin"  ,
StringCategory  ,
"draft-hixie- thewebsocketprotocol-76"   
)

◆ defineHeader() [26/52]

defineHeader ( PCalledPartyId  ,
"P-Called-Party-ID"  ,
NameAddr  ,
"RFC 3455"   
)

◆ defineHeader() [27/52]

defineHeader ( PChargingFunctionAddresses  ,
"P-Charging-Function-Addresses"  ,
Token  ,
"RFC 3455"   
)

◆ defineHeader() [28/52]

defineHeader ( PChargingVector  ,
"P-Charging-Vector"  ,
Token  ,
"RFC 3455"   
)

◆ defineHeader() [29/52]

defineHeader ( Priority  ,
"Priority"  ,
Token  ,
"RFC 3261"   
)

◆ defineHeader() [30/52]

defineHeader ( PrivAnswerMode  ,
"Priv-Answer-Mode"  ,
Token  ,
"draft-ietf-answermode-01"   
)

◆ defineHeader() [31/52]

defineHeader ( RAck  ,
"RAck"  ,
RAckCategory  ,
"RFC 3262"   
)

◆ defineHeader() [32/52]

defineHeader ( ReferredBy  ,
"Referred-By"  ,
NameAddr  ,
"RFC 3892"   
)

◆ defineHeader() [33/52]

defineHeader ( ReferSub  ,
"Refer-Sub"  ,
Token  ,
"RFC 4488"   
)

◆ defineHeader() [34/52]

defineHeader ( ReferTo  ,
"Refer-To"  ,
NameAddr  ,
"RFC 3515"   
)

◆ defineHeader() [35/52]

defineHeader ( Replaces  ,
"Replaces"  ,
CallId  ,
"RFC 3891"   
)

◆ defineHeader() [36/52]

defineHeader ( ReplyTo  ,
"Reply-To"  ,
NameAddr  ,
"RFC 3261"   
)

◆ defineHeader() [37/52]

defineHeader ( RetryAfter  ,
"Retry-After"  ,
UInt32Category  ,
"RFC 3261"   
)

◆ defineHeader() [38/52]

defineHeader ( RSeq  ,
"RSeq"  ,
UInt32Category  ,
"RFC 3262"   
)

◆ defineHeader() [39/52]

defineHeader ( SecWebSocketAccept  ,
"Sec-WebSocket-Accept"  ,
StringCategory  ,
"RFC 6455"   
)

◆ defineHeader() [40/52]

defineHeader ( SecWebSocketKey  ,
"Sec-WebSocket-Key"  ,
StringCategory  ,
"RFC 6455"   
)

◆ defineHeader() [41/52]

defineHeader ( SecWebSocketKey1  ,
"Sec-WebSocket-Key1"  ,
StringCategory  ,
"draft-hixie- thewebsocketprotocol-76"   
)

◆ defineHeader() [42/52]

defineHeader ( SecWebSocketKey2  ,
"Sec-WebSocket-Key2"  ,
StringCategory  ,
"draft-hixie- thewebsocketprotocol-76"   
)

◆ defineHeader() [43/52]

defineHeader ( Server  ,
"Server"  ,
StringCategory  ,
"RFC 3261"   
)

◆ defineHeader() [44/52]

defineHeader ( SessionExpires  ,
"Session-Expires"  ,
ExpiresCategory  ,
"RFC 4028"   
)

◆ defineHeader() [45/52]

defineHeader ( SIPETag  ,
"SIP-ETag"  ,
Token  ,
"RFC 3903"   
)

◆ defineHeader() [46/52]

defineHeader ( SIPIfMatch  ,
"SIP-If-Match"  ,
Token  ,
"RFC 3903"   
)

◆ defineHeader() [47/52]

defineHeader ( Subject  ,
"Subject"  ,
StringCategory  ,
"RFC 3261"   
)

◆ defineHeader() [48/52]

defineHeader ( SubscriptionState  ,
"Subscription-State"  ,
Token  ,
"RFC 3265"   
)

◆ defineHeader() [49/52]

defineHeader ( TargetDialog  ,
"Target-Dialog"  ,
CallId  ,
"RFC 4538"   
)

◆ defineHeader() [50/52]

defineHeader ( Timestamp  ,
"Timestamp"  ,
StringCategory  ,
"RFC 3261"   
)

◆ defineHeader() [51/52]

defineHeader ( To  ,
"To"  ,
NameAddr  ,
"RFC 3261"   
)

◆ defineHeader() [52/52]

defineHeader ( UserAgent  ,
"User-Agent"  ,
StringCategory  ,
"RFC 3261"   
)

◆ defineMultiHeader() [1/44]

defineMultiHeader ( Accept  ,
"Accept"  ,
Mime  ,
"RFC 3261"   
)

◆ defineMultiHeader() [2/44]

defineMultiHeader ( AcceptContact  ,
"Accept-Contact"  ,
NameAddr  ,
"RFC 3841"   
)

◆ defineMultiHeader() [3/44]

defineMultiHeader ( AcceptEncoding  ,
"Accept-Encoding"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [4/44]

defineMultiHeader ( AcceptLanguage  ,
"Accept-Language"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [5/44]

defineMultiHeader ( AlertInfo  ,
"Alert-Info"  ,
GenericUri  ,
"RFC 3261"   
)

◆ defineMultiHeader() [6/44]

defineMultiHeader ( Allow  ,
"Allow"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [7/44]

defineMultiHeader ( AllowEvents  ,
"Allow-Events"  ,
Token  ,
"RFC 3265"   
)

◆ defineMultiHeader() [8/44]

defineMultiHeader ( Authorization  ,
"Authorization"  ,
Auth  ,
"RFC 3261"   
)

◆ defineMultiHeader() [9/44]

defineMultiHeader ( CallInfo  ,
"Call-Info"  ,
GenericUri  ,
"RFC 3261"   
)

◆ defineMultiHeader() [10/44]

defineMultiHeader ( Contact  ,
"Contact"  ,
NameAddr  ,
"RFC 3261"   
)

◆ defineMultiHeader() [11/44]

defineMultiHeader ( ContentLanguage  ,
"Content-Language"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [12/44]

defineMultiHeader ( Cookie  ,
"Cookie"  ,
StringCategory  ,
"RFC 6265"   
)

◆ defineMultiHeader() [13/44]

defineMultiHeader ( Diversion  ,
"Diversion"  ,
NameAddr  ,
"RFC 5806"   
)

◆ defineMultiHeader() [14/44]

defineMultiHeader ( ErrorInfo  ,
"Error-Info"  ,
GenericUri  ,
"RFC 3261"   
)

◆ defineMultiHeader() [15/44]

defineMultiHeader ( HistoryInfo  ,
"History-Info"  ,
NameAddr  ,
"RFC 4244"   
)

◆ defineMultiHeader() [16/44]

defineMultiHeader ( Identity  ,
"Identity"  ,
IdentityCategory  ,
"RFC 8224"   
)

◆ defineMultiHeader() [17/44]

defineMultiHeader ( PAccessNetworkInfo  ,
"P-Access-Network-Info"  ,
Token  ,
"RFC 7315"   
)

◆ defineMultiHeader() [18/44]

defineMultiHeader ( PAssertedIdentity  ,
"P-Asserted-Identity"  ,
NameAddr  ,
"RFC 3325"   
)

◆ defineMultiHeader() [19/44]

defineMultiHeader ( PAssociatedUri  ,
"P-Associated-URI"  ,
NameAddr  ,
"RFC 3455"   
)

◆ defineMultiHeader() [20/44]

defineMultiHeader ( Path  ,
"Path"  ,
NameAddr  ,
"RFC 3327"   
)

◆ defineMultiHeader() [21/44]

defineMultiHeader ( PMediaAuthorization  ,
"P-Media-Authorization"  ,
Token  ,
"RFC 3313"   
)

◆ defineMultiHeader() [22/44]

defineMultiHeader ( PPreferredIdentity  ,
"P-Preferred-Identity"  ,
NameAddr  ,
"RFC 3325"   
)

◆ defineMultiHeader() [23/44]

defineMultiHeader ( Privacy  ,
"Privacy"  ,
PrivacyCategory  ,
"RFC 3323"   
)

◆ defineMultiHeader() [24/44]

defineMultiHeader ( ProxyAuthenticate  ,
"Proxy-Authenticate"  ,
Auth  ,
"RFC 3261"   
)

◆ defineMultiHeader() [25/44]

defineMultiHeader ( ProxyAuthorization  ,
"Proxy-Authorization"  ,
Auth  ,
"RFC 3261"   
)

◆ defineMultiHeader() [26/44]

defineMultiHeader ( ProxyRequire  ,
"Proxy-Require"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [27/44]

defineMultiHeader ( PVisitedNetworkID  ,
"P-Visited-Network-ID"  ,
TokenOrQuotedStringCategory  ,
"RFC 3455"   
)

◆ defineMultiHeader() [28/44]

defineMultiHeader ( Reason  ,
"Reason"  ,
Token  ,
"RFC 3326"   
)

◆ defineMultiHeader() [29/44]

defineMultiHeader ( RecordRoute  ,
"Record-Route"  ,
NameAddr  ,
"RFC 3261"   
)

◆ defineMultiHeader() [30/44]

defineMultiHeader ( RejectContact  ,
"Reject-Contact"  ,
NameAddr  ,
"RFC 3841"   
)

◆ defineMultiHeader() [31/44]

defineMultiHeader ( RemotePartyId  ,
"Remote-Party-ID"  ,
NameAddr  ,
"draft-ietf-sip-privacy-04"   
)

◆ defineMultiHeader() [32/44]

defineMultiHeader ( RequestDisposition  ,
"Request-Disposition"  ,
Token  ,
"RFC 3841"   
)

◆ defineMultiHeader() [33/44]

defineMultiHeader ( Require  ,
"Require"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [34/44]

defineMultiHeader ( Route  ,
"Route"  ,
NameAddr  ,
"RFC 3261"   
)

◆ defineMultiHeader() [35/44]

defineMultiHeader ( SecurityClient  ,
"Security-Client"  ,
Token  ,
"RFC 3329"   
)

◆ defineMultiHeader() [36/44]

defineMultiHeader ( SecurityServer  ,
"Security-Server"  ,
Token  ,
"RFC 3329"   
)

◆ defineMultiHeader() [37/44]

defineMultiHeader ( SecurityVerify  ,
"Security-Verify"  ,
Token  ,
"RFC 3329"   
)

◆ defineMultiHeader() [38/44]

defineMultiHeader ( ServiceRoute  ,
"Service-Route"  ,
NameAddr  ,
"RFC 3608"   
)

◆ defineMultiHeader() [39/44]

defineMultiHeader ( Supported  ,
"Supported"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [40/44]

defineMultiHeader ( Unsupported  ,
"Unsupported"  ,
Token  ,
"RFC 3261"   
)

◆ defineMultiHeader() [41/44]

defineMultiHeader ( UserToUser  ,
"User-to-User"  ,
TokenOrQuotedStringCategory  ,
"draft-ietf-cuss-sip-uui-17"   
)

◆ defineMultiHeader() [42/44]

defineMultiHeader ( Via  ,
"Via"  ,
Via  ,
"RFC 3261"   
)

◆ defineMultiHeader() [43/44]

defineMultiHeader ( Warning  ,
"Warning"  ,
WarningCategory  ,
"RFC 3261"   
)

◆ defineMultiHeader() [44/44]

defineMultiHeader ( WWWAuthenticate  ,
"WWW-Authenticate"  ,
Auth  ,
"RFC 3261"   
)