reSIProcate
SIP stack, Dialog Usage Manager and related libraries
Loading...
Searching...
No Matches
Headers.hxx
Go to the documentation of this file.
1#if !defined(RESIP_HEADERS_HXX)
2#define RESIP_HEADERS_HXX
3
7#include "rutil/Data.hxx"
9
10namespace resip
11{
12class SipMessage;
13class HeaderFieldValueList;
14
15//#define PARTIAL_TEMPLATE_SPECIALIZATION
16#ifdef PARTIAL_TEMPLATE_SPECIALIZATION
17template<bool>
18class TypeIf
19{
20 public:
21 template <class T>
22 class Resolve
23 {
24 public:
25 typedef T Type;
26 };
27};
28
29class UnusedHeader
30{
31};
32
33class TypeIf<false>
34{
35 public:
36 template <class T>
37 class Resolve
38 {
39 public:
40 typedef UnusedHeader Type;
41 };
42};
43
44#define UnusedChecking(_enum) \
45 typedef TypeIf<Headers::_enum != Headers::UNKNOWN> TypeIfT; \
46 typedef TypeIfT::Resolve<Type> Resolver; \
47 typedef Resolver::Type UnknownReturn
48
49#define MultiUnusedChecking(_enum) \
50 typedef TypeIf<Headers::_enum != Headers::UNKNOWN> TypeIfT; \
51 typedef TypeIfT::Resolve< ParserContainer<Type> > Resolver; \
52 typedef Resolver::Type UnknownReturn
53
54#else
55
56#define UnusedChecking(_enum) typedef int _dummy
57#define MultiUnusedChecking(_enum) typedef int _dummy
58
59#endif
60
62{
63 public:
64 virtual ~HeaderBase() {}
65 virtual Headers::Type getTypeNum() const = 0;
66 virtual void merge(SipMessage&, const SipMessage&)=0;
67
69 {
70 return theHeaderInstances[typenum+1];
71 }
72
74 protected:
76};
77
78#define defineHeader(_enum, _name, _type, _rfc) \
79class H_##_enum : public HeaderBase \
80{ \
81 public: \
82 RESIP_HeapCount(H_##_enum); \
83 enum {Single = true}; \
84 typedef _type Type; \
85 UnusedChecking(_enum); \
86 static Type& knownReturn(ParserContainerBase* container); \
87 virtual ParserContainerBase* makeContainer(HeaderFieldValueList* hfvs) const; \
88 virtual Headers::Type getTypeNum() const; \
89 virtual void merge(SipMessage&, const SipMessage&); \
90 H_##_enum(); \
91}; \
92extern H_##_enum h_##_enum
93
94#define defineMultiHeader(_enum, _name, _type, _rfc) \
95class H_##_enum##s : public HeaderBase \
96{ \
97 public: \
98 RESIP_HeapCount(H_##_enum##s); \
99 enum {Single = false}; \
100 typedef ParserContainer<_type> Type; \
101 typedef _type ContainedType; \
102 MultiUnusedChecking(_enum); \
103 static Type& knownReturn(ParserContainerBase* container); \
104 virtual ParserContainerBase* makeContainer(HeaderFieldValueList* hfvs) const; \
105 virtual Headers::Type getTypeNum() const; \
106 virtual void merge(SipMessage&, const SipMessage&); \
107 H_##_enum##s(); \
108}; \
109extern H_##_enum##s h_##_enum##s
110
111//====================
112// Token:
113//====================
115
116defineHeader(ContentDisposition, "Content-Disposition", Token, "RFC 3261");
117defineHeader(ContentEncoding, "Content-Encoding", Token, "RFC 3261");
118defineHeader(MIMEVersion, "Mime-Version", Token, "RFC 3261");
119defineHeader(Priority, "Priority", Token, "RFC 3261");
120defineHeader(Event, "Event", Token, "RFC 3265");
121defineHeader(SubscriptionState, "Subscription-State", Token, "RFC 3265");
122
123defineHeader(SIPETag, "SIP-ETag", Token, "RFC 3903");
124defineHeader(SIPIfMatch, "SIP-If-Match", Token, "RFC 3903");
125defineHeader(ContentId, "Content-ID", Token, "RFC 2045");
126
127defineMultiHeader(AllowEvents, "Allow-Events", Token, "RFC 3265");
128// explicitly declare to avoid h_AllowEventss, ugh
129extern H_AllowEventss h_AllowEvents;
130
131defineMultiHeader(AcceptEncoding, "Accept-Encoding", Token, "RFC 3261");
132defineMultiHeader(AcceptLanguage, "Accept-Language", Token, "RFC 3261");
133defineMultiHeader(Allow, "Allow", Token, "RFC 3261");
134defineMultiHeader(ContentLanguage, "Content-Language", Token, "RFC 3261");
135defineMultiHeader(ProxyRequire, "Proxy-Require", Token, "RFC 3261");
136defineMultiHeader(Require, "Require", Token, "RFC 3261");
137defineMultiHeader(Supported, "Supported", Token, "RFC 3261");
138defineMultiHeader(Unsupported, "Unsupported", Token, "RFC 3261");
139defineMultiHeader(SecurityClient, "Security-Client", Token, "RFC 3329");
140defineMultiHeader(SecurityServer, "Security-Server", Token, "RFC 3329");
141defineMultiHeader(SecurityVerify, "Security-Verify", Token, "RFC 3329");
142// explicitly declare to avoid h_SecurityVerifys, ugh
143extern H_SecurityVerifys h_SecurityVerifies;
144
145defineMultiHeader(RequestDisposition, "Request-Disposition", Token, "RFC 3841");
146defineMultiHeader(Reason, "Reason", Token, "RFC 3326");
147defineMultiHeader(Privacy, "Privacy", PrivacyCategory, "RFC 3323");
148// explicitly declare to avoid h_Privacys
149extern H_Privacys h_Privacies;
150
151defineMultiHeader(PMediaAuthorization, "P-Media-Authorization", Token, "RFC 3313");
152
153defineHeader(ReferSub, "Refer-Sub", Token, "RFC 4488");
154defineHeader(AnswerMode, "Answer-Mode", Token, "draft-ietf-answermode-01");
155defineHeader(PrivAnswerMode, "Priv-Answer-Mode", Token, "draft-ietf-answermode-01");
156
157defineMultiHeader(PAccessNetworkInfo, "P-Access-Network-Info", Token, "RFC 7315"); // section 5.4.
158defineHeader(PChargingVector, "P-Charging-Vector", Token, "RFC 3455");
159defineHeader(PChargingFunctionAddresses, "P-Charging-Function-Addresses", Token, "RFC 3455");
160
161//====================
162// Mime
163//====================
165
166defineMultiHeader(Accept, "Accept", Mime, "RFC 3261");
167defineHeader(ContentType, "Content-Type", Mime, "RFC 3261");
168
169//====================
170// GenericUris:
171//====================
173defineMultiHeader(CallInfo, "Call-Info", GenericUri, "RFC 3261");
174defineMultiHeader(AlertInfo, "Alert-Info", GenericUri, "RFC 3261");
175defineMultiHeader(ErrorInfo, "Error-Info", GenericUri, "RFC 3261");
176defineHeader(IdentityInfo, "Identity-Info", GenericUri, "RFC 4474"); // deprecated by RFC8224
177
178//====================
179// NameAddr:
180//====================
182
183defineMultiHeader(RecordRoute, "Record-Route", NameAddr, "RFC 3261");
184defineMultiHeader(Route, "Route", NameAddr, "RFC 3261");
185defineMultiHeader(Contact, "Contact", NameAddr, "RFC 3261");
186defineHeader(From, "From", NameAddr, "RFC 3261");
187defineHeader(To, "To", NameAddr, "RFC 3261");
188defineHeader(ReplyTo, "Reply-To", NameAddr, "RFC 3261");
189defineHeader(ReferTo, "Refer-To", NameAddr, "RFC 3515");
190defineHeader(ReferredBy, "Referred-By", NameAddr, "RFC 3892");
191
192defineMultiHeader(Path, "Path", NameAddr, "RFC 3327");
193defineMultiHeader(AcceptContact, "Accept-Contact", NameAddr, "RFC 3841");
194defineMultiHeader(RejectContact, "Reject-Contact", NameAddr, "RFC 3841");
195defineMultiHeader(PPreferredIdentity, "P-Preferred-Identity", NameAddr, "RFC 3325");
196// explicitly declare to avoid h_PAssertedIdentitys
197extern H_PPreferredIdentitys h_PPreferredIdentities;
198
199defineMultiHeader(PAssertedIdentity, "P-Asserted-Identity", NameAddr, "RFC 3325");
200// explicitly declare to avoid h_PAssertedIdentitys
201extern H_PAssertedIdentitys h_PAssertedIdentities;
202
203defineHeader(PCalledPartyId, "P-Called-Party-ID", NameAddr, "RFC 3455");
204defineMultiHeader(PAssociatedUri, "P-Associated-URI", NameAddr, "RFC 3455");
205defineMultiHeader(ServiceRoute, "Service-Route", NameAddr, "RFC 3608");
206defineMultiHeader(RemotePartyId, "Remote-Party-ID", NameAddr, "draft-ietf-sip-privacy-04"); // ?bwc? Not in 3323, should we keep?
207defineMultiHeader(HistoryInfo, "History-Info", NameAddr, "RFC 4244");
208defineMultiHeader(Diversion, "Diversion", NameAddr, "RFC 5806");
209
210//====================
211// StringCategory:
212//====================
214
215defineHeader(ContentTransferEncoding, "Content-Transfer-Encoding", StringCategory, "RFC ?");
216defineHeader(Organization, "Organization", StringCategory, "RFC 3261");
217defineHeader(SecWebSocketKey, "Sec-WebSocket-Key", StringCategory, "RFC 6455");
218defineHeader(SecWebSocketKey1, "Sec-WebSocket-Key1", StringCategory, "draft-hixie- thewebsocketprotocol-76");
219defineHeader(SecWebSocketKey2, "Sec-WebSocket-Key2", StringCategory, "draft-hixie- thewebsocketprotocol-76");
220defineHeader(Origin, "Origin", StringCategory, "draft-hixie- thewebsocketprotocol-76");
221defineHeader(Host, "Host", StringCategory, "draft-hixie- thewebsocketprotocol-76");
222defineHeader(SecWebSocketAccept, "Sec-WebSocket-Accept", StringCategory, "RFC 6455");
224defineHeader(Server, "Server", StringCategory, "RFC 3261");
225defineHeader(Subject, "Subject", StringCategory, "RFC 3261");
226defineHeader(UserAgent, "User-Agent", StringCategory, "RFC 3261");
227defineHeader(Timestamp, "Timestamp", StringCategory, "RFC 3261");
228
229//====================
230// ExpiresCategory:
231//====================
232
233defineHeader(Expires, "Expires", ExpiresCategory, "RFC 3261");
234defineHeader(SessionExpires, "Session-Expires", ExpiresCategory, "RFC 4028");
235defineHeader(MinSE, "Min-SE", ExpiresCategory, "RFC 4028");
236
237//====================
238// UInt32Category:
239//====================
241defineHeader(MaxForwards, "Max-Forwards", UInt32Category, "RFC 3261");
242// !dlb! not clear this needs to be exposed
243defineHeader(ContentLength, "Content-Length", UInt32Category, "RFC 3261");
244defineHeader(MinExpires, "Min-Expires", UInt32Category, "RFC 3261");
245defineHeader(RSeq, "RSeq", UInt32Category, "RFC 3261");
246
247// !dlb! this one is not quite right -- can have (comment) after field value
248defineHeader(RetryAfter, "Retry-After", UInt32Category, "RFC 3261");
249defineHeader(FlowTimer, "Flow-Timer", UInt32Category, "RFC 5626");
250
251//====================
252// CallId:
253//====================
254defineHeader(CallID, "Call-ID", CallID, "RFC 3261");
255defineHeader(Replaces, "Replaces", CallID, "RFC 3891");
256defineHeader(InReplyTo, "In-Reply-To", CallID, "RFC 3261");
257
258typedef H_CallID H_CallId; // code convention compatible
259extern H_CallId h_CallId; // code convention compatible
260
261defineHeader(Join, "Join", CallId, "RFC 3911");
262defineHeader(TargetDialog, "Target-Dialog", CallId, "RFC 4538");
263
264
265//====================
266// Auth:
267//====================
269defineHeader(AuthenticationInfo, "Authentication-Info", Auth, "RFC 3261");
270defineMultiHeader(Authorization, "Authorization", Auth, "RFC 3261");
271defineMultiHeader(ProxyAuthenticate, "Proxy-Authenticate", Auth, "RFC 3261");
272defineMultiHeader(ProxyAuthorization, "Proxy-Authorization", Auth, "RFC 3261");
273defineMultiHeader(WWWAuthenticate, "Www-Authenticate", Auth, "RFC 3261");
274
275//====================
276// CSeqCategory:
277//====================
278defineHeader(CSeq, "CSeq", CSeqCategory, "RFC 3261");
279
280//====================
281// DateCategory:
282//====================
283defineHeader(Date, "Date", DateCategory, "RFC 3261");
284
285//====================
286// WarningCategory:
287//====================
288defineMultiHeader(Warning, "Warning", WarningCategory, "RFC 3261");
289
290//Enforces string encoding of extension headers
291defineMultiHeader(RESIP_DO_NOT_USE, "If you see this things are seriously awry", StringCategory, "NA");
292
293//====================
294// Via
295//====================
297defineMultiHeader(Via, "Via", Via, "RFC 3261");
298
299//====================
300// RAckCategory
301//====================
302defineHeader(RAck, "RAck", RAckCategory, "RFC 3262");
303
304//============================
305// TokenOrQuotedStringCategory
306//============================
307defineMultiHeader(PVisitedNetworkID, "P-Visited-Network-ID", TokenOrQuotedStringCategory, "RFC 3455");
308defineMultiHeader(UserToUser, "User-to-User", TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17");
309
310//============================
311// IdentityCategory
312//============================
314defineMultiHeader(Identity, "Identity", IdentityCategory, "RFC 8224"); // Originally defined in RFC 4474 as a single header, but later modified by RFC8224 to be a multiheader
315// explicitly declare to avoid h_Identitys
316extern H_Identitys h_Identities;
317
318//====================
319// special first line accessors
320//====================
323
326
327}
328
329#undef defineHeader
330#undef defineMultiHeader
331
332#endif
333
334/* ====================================================================
335 * The Vovida Software License, Version 1.0
336 *
337 * Copyright (c) 2026 SIP Spectrum, Inc. https://www.sipspectrum.com
338 * Copyright (c) 2000 Vovida Networks, Inc. All rights reserved.
339 *
340 * Redistribution and use in source and binary forms, with or without
341 * modification, are permitted provided that the following conditions
342 * are met:
343 *
344 * 1. Redistributions of source code must retain the above copyright
345 * notice, this list of conditions and the following disclaimer.
346 *
347 * 2. Redistributions in binary form must reproduce the above copyright
348 * notice, this list of conditions and the following disclaimer in
349 * the documentation and/or other materials provided with the
350 * distribution.
351 *
352 * 3. The names "VOCAL", "Vovida Open Communication Application Library",
353 * and "Vovida Open Communication Application Library (VOCAL)" must
354 * not be used to endorse or promote products derived from this
355 * software without prior written permission. For written
356 * permission, please contact vocal@vovida.org.
357 *
358 * 4. Products derived from this software may not be called "VOCAL", nor
359 * may "VOCAL" appear in their name, without prior written
360 * permission of Vovida Networks, Inc.
361 *
362 * THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED
363 * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
364 * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND
365 * NON-INFRINGEMENT ARE DISCLAIMED. IN NO EVENT SHALL VOVIDA
366 * NETWORKS, INC. OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT DAMAGES
367 * IN EXCESS OF $1,000, NOR FOR ANY INDIRECT, INCIDENTAL, SPECIAL,
368 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
369 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
370 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
371 * OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
372 * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
373 * USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
374 * DAMAGE.
375 *
376 * ====================================================================
377 *
378 * This software consists of voluntary contributions made by Vovida
379 * Networks, Inc. and many individuals on behalf of Vovida Networks,
380 * Inc. For more information on Vovida Networks, Inc., please see
381 * <http://www.vovida.org/>.
382 *
383 */
#define defineHeader(_enum, _name, _type, _reference)
Definition Headers.cxx:55
#define defineMultiHeader(_enum, _name, _type, _reference)
Definition Headers.cxx:90
Represents the "credentials" and "challenge" elements in the SIP grammar.
Definition Auth.hxx:18
Represents a CSeq header field value (this doesn't have an official name in the RFC 3261 grammar).
Represents the "callid" element in the SIP grammar.
Definition CallId.hxx:18
Represents the "SIP-date" element in the RFC 3261 grammar.
Represents the header field value for an Expires-type header.
Represents the "absoluteURI" element in the RFC 3261 grammar.
static HeaderBase * getInstance(Headers::Type typenum)
Definition Headers.hxx:68
virtual ~HeaderBase()
Definition Headers.hxx:64
static HeaderBase * theHeaderInstances[Headers::MAX_HEADERS+1]
Definition Headers.hxx:75
virtual Headers::Type getTypeNum() const =0
virtual ParserContainerBase * makeContainer(HeaderFieldValueList *hfvs) const =0
virtual void merge(SipMessage &, const SipMessage &)=0
Represents an Identity header from RFC8824.
Represents the "media-type" element in the RFC 3261 grammar.
Definition Mime.hxx:20
Represents the "name-addr" and the "addr-spec" elements in the RFC 3261 grammar.
Definition NameAddr.hxx:19
Abstract Base class implemented in derived class ParserContainer.
Container class for ParserCategory, used by SipMessage to represent multi-valued headers (Contact,...
Represents the "token" element in the RFC 3261 grammar.
Represents the RAck header field value defined in the RFC 3262 grammar.
Represents a SIP message.
Represents the "header-value" element in the RFC 3261 grammar (ie, an unknown header field value).
Generically represents a token whose value can be wrapped and encoded using double quotes.
Represents the "token" element in the RFC 3261 grammar.
Definition Token.hxx:18
Represents a numeric-with-comment header field value.
Represents the "via-parm" element in the RFC 3261 grammar.
Definition Via.hxx:18
Represents the "warning-value" element in the RFC 3261 grammar.
dcm! – add UnusedChecking(_enum) below;
StatusLineType h_StatusLine
Definition Headers.cxx:348
ParserContainer< Via > Vias
Definition Headers.hxx:296
ParserContainer< Mime > Mimes
Definition Headers.hxx:164
ParserContainer< GenericUri > GenericUris
ParserContainer< Token > Tokens
Definition Headers.hxx:114
ParserContainer< IdentityCategory > IdentityCategories
Definition Headers.hxx:313
H_Privacys h_Privacies
Definition Headers.cxx:163
ParserContainer< Auth > Auths
Definition Headers.hxx:268
H_PPreferredIdentitys h_PPreferredIdentities
Definition Headers.cxx:211
H_SecurityVerifys h_SecurityVerifies
Definition Headers.cxx:157
H_CallID H_CallId
Definition Headers.hxx:258
H_PAssertedIdentitys h_PAssertedIdentities
Definition Headers.cxx:215
ParserContainer< NameAddr > NameAddrs
Definition Headers.hxx:181
H_Identitys h_Identities
Definition Headers.cxx:315
RequestLineType h_RequestLine
Definition Headers.cxx:347
ParserContainer< StringCategory > StringCategories
Definition Headers.hxx:213
ParserContainer< UInt32Category > UInt32Categories
Definition Headers.hxx:240
H_AllowEventss h_AllowEvents
Definition Headers.cxx:143
H_CallId h_CallId
Definition Headers.cxx:266
void list()
Definition userAdmin.cxx:66