|
| | resip::defineHeader (ContentDisposition, "Content-Disposition", Token, "RFC 3261") |
| |
| | resip::defineHeader (ContentEncoding, "Content-Encoding", Token, "RFC 3261") |
| |
| | resip::defineHeader (MIMEVersion, "Mime-Version", Token, "RFC 3261") |
| |
| | resip::defineHeader (Priority, "Priority", Token, "RFC 3261") |
| |
| | resip::defineHeader (Event, "Event", Token, "RFC 3265") |
| |
| | resip::defineHeader (SubscriptionState, "Subscription-State", Token, "RFC 3265") |
| |
| | resip::defineHeader (SIPETag, "SIP-ETag", Token, "RFC 3903") |
| |
| | resip::defineHeader (SIPIfMatch, "SIP-If-Match", Token, "RFC 3903") |
| |
| | resip::defineHeader (ContentId, "Content-ID", Token, "RFC 2045") |
| |
| | resip::defineMultiHeader (AllowEvents, "Allow-Events", Token, "RFC 3265") |
| |
| | resip::defineMultiHeader (AcceptEncoding, "Accept-Encoding", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (AcceptLanguage, "Accept-Language", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (Allow, "Allow", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (ContentLanguage, "Content-Language", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (ProxyRequire, "Proxy-Require", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (Require, "Require", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (Supported, "Supported", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (Unsupported, "Unsupported", Token, "RFC 3261") |
| |
| | resip::defineMultiHeader (SecurityClient, "Security-Client", Token, "RFC 3329") |
| |
| | resip::defineMultiHeader (SecurityServer, "Security-Server", Token, "RFC 3329") |
| |
| | resip::defineMultiHeader (SecurityVerify, "Security-Verify", Token, "RFC 3329") |
| |
| | resip::defineMultiHeader (RequestDisposition, "Request-Disposition", Token, "RFC 3841") |
| |
| | resip::defineMultiHeader (Reason, "Reason", Token, "RFC 3326") |
| |
| | resip::defineMultiHeader (Privacy, "Privacy", PrivacyCategory, "RFC 3323") |
| |
| | resip::defineMultiHeader (PMediaAuthorization, "P-Media-Authorization", Token, "RFC 3313") |
| |
| | resip::defineHeader (ReferSub, "Refer-Sub", Token, "RFC 4488") |
| |
| | resip::defineHeader (AnswerMode, "Answer-Mode", Token, "draft-ietf-answermode-01") |
| |
| | resip::defineHeader (PrivAnswerMode, "Priv-Answer-Mode", Token, "draft-ietf-answermode-01") |
| |
| | resip::defineMultiHeader (PAccessNetworkInfo, "P-Access-Network-Info", Token, "RFC 7315") |
| |
| | resip::defineHeader (PChargingVector, "P-Charging-Vector", Token, "RFC 3455") |
| |
| | resip::defineHeader (PChargingFunctionAddresses, "P-Charging-Function-Addresses", Token, "RFC 3455") |
| |
| | resip::defineMultiHeader (Accept, "Accept", Mime, "RFC 3261") |
| |
| | resip::defineHeader (ContentType, "Content-Type", Mime, "RFC 3261") |
| |
| | resip::defineMultiHeader (CallInfo, "Call-Info", GenericUri, "RFC 3261") |
| |
| | resip::defineMultiHeader (AlertInfo, "Alert-Info", GenericUri, "RFC 3261") |
| |
| | resip::defineMultiHeader (ErrorInfo, "Error-Info", GenericUri, "RFC 3261") |
| |
| | resip::defineHeader (IdentityInfo, "Identity-Info", GenericUri, "RFC 4474") |
| |
| | resip::defineMultiHeader (RecordRoute, "Record-Route", NameAddr, "RFC 3261") |
| |
| | resip::defineMultiHeader (Route, "Route", NameAddr, "RFC 3261") |
| |
| | resip::defineMultiHeader (Contact, "Contact", NameAddr, "RFC 3261") |
| |
| | resip::defineHeader (From, "From", NameAddr, "RFC 3261") |
| |
| | resip::defineHeader (To, "To", NameAddr, "RFC 3261") |
| |
| | resip::defineHeader (ReplyTo, "Reply-To", NameAddr, "RFC 3261") |
| |
| | resip::defineHeader (ReferTo, "Refer-To", NameAddr, "RFC 3515") |
| |
| | resip::defineHeader (ReferredBy, "Referred-By", NameAddr, "RFC 3892") |
| |
| | resip::defineMultiHeader (Path, "Path", NameAddr, "RFC 3327") |
| |
| | resip::defineMultiHeader (AcceptContact, "Accept-Contact", NameAddr, "RFC 3841") |
| |
| | resip::defineMultiHeader (RejectContact, "Reject-Contact", NameAddr, "RFC 3841") |
| |
| | resip::defineMultiHeader (PPreferredIdentity, "P-Preferred-Identity", NameAddr, "RFC 3325") |
| |
| | resip::defineMultiHeader (PAssertedIdentity, "P-Asserted-Identity", NameAddr, "RFC 3325") |
| |
| | resip::defineHeader (PCalledPartyId, "P-Called-Party-ID", NameAddr, "RFC 3455") |
| |
| | resip::defineMultiHeader (PAssociatedUri, "P-Associated-URI", NameAddr, "RFC 3455") |
| |
| | resip::defineMultiHeader (ServiceRoute, "Service-Route", NameAddr, "RFC 3608") |
| |
| | resip::defineMultiHeader (RemotePartyId, "Remote-Party-ID", NameAddr, "draft-ietf-sip-privacy-04") |
| |
| | resip::defineMultiHeader (HistoryInfo, "History-Info", NameAddr, "RFC 4244") |
| |
| | resip::defineMultiHeader (Diversion, "Diversion", NameAddr, "RFC 5806") |
| |
| | resip::defineHeader (ContentTransferEncoding, "Content-Transfer-Encoding", StringCategory, "RFC ?") |
| |
| | resip::defineHeader (Organization, "Organization", StringCategory, "RFC 3261") |
| |
| | resip::defineHeader (SecWebSocketKey, "Sec-WebSocket-Key", StringCategory, "RFC 6455") |
| |
| | resip::defineHeader (SecWebSocketKey1, "Sec-WebSocket-Key1", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | resip::defineHeader (SecWebSocketKey2, "Sec-WebSocket-Key2", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | resip::defineHeader (Origin, "Origin", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | resip::defineHeader (Host, "Host", StringCategory, "draft-hixie- thewebsocketprotocol-76") |
| |
| | resip::defineHeader (SecWebSocketAccept, "Sec-WebSocket-Accept", StringCategory, "RFC 6455") |
| |
| | resip::defineMultiHeader (Cookie, "Cookie", StringCategory, "RFC 6265") |
| |
| | resip::defineHeader (Server, "Server", StringCategory, "RFC 3261") |
| |
| | resip::defineHeader (Subject, "Subject", StringCategory, "RFC 3261") |
| |
| | resip::defineHeader (UserAgent, "User-Agent", StringCategory, "RFC 3261") |
| |
| | resip::defineHeader (Timestamp, "Timestamp", StringCategory, "RFC 3261") |
| |
| | resip::defineHeader (Expires, "Expires", ExpiresCategory, "RFC 3261") |
| |
| | resip::defineHeader (SessionExpires, "Session-Expires", ExpiresCategory, "RFC 4028") |
| |
| | resip::defineHeader (MinSE, "Min-SE", ExpiresCategory, "RFC 4028") |
| |
| | resip::defineHeader (MaxForwards, "Max-Forwards", UInt32Category, "RFC 3261") |
| |
| | resip::defineHeader (ContentLength, "Content-Length", UInt32Category, "RFC 3261") |
| |
| | resip::defineHeader (MinExpires, "Min-Expires", UInt32Category, "RFC 3261") |
| |
| | resip::defineHeader (RSeq, "RSeq", UInt32Category, "RFC 3261") |
| |
| | resip::defineHeader (RetryAfter, "Retry-After", UInt32Category, "RFC 3261") |
| |
| | resip::defineHeader (FlowTimer, "Flow-Timer", UInt32Category, "RFC 5626") |
| |
| | resip::defineHeader (CallID, "Call-ID", CallID, "RFC 3261") |
| |
| | resip::defineHeader (Replaces, "Replaces", CallID, "RFC 3891") |
| |
| | resip::defineHeader (InReplyTo, "In-Reply-To", CallID, "RFC 3261") |
| |
| | resip::defineHeader (Join, "Join", CallId, "RFC 3911") |
| |
| | resip::defineHeader (TargetDialog, "Target-Dialog", CallId, "RFC 4538") |
| |
| | resip::defineHeader (AuthenticationInfo, "Authentication-Info", Auth, "RFC 3261") |
| |
| | resip::defineMultiHeader (Authorization, "Authorization", Auth, "RFC 3261") |
| |
| | resip::defineMultiHeader (ProxyAuthenticate, "Proxy-Authenticate", Auth, "RFC 3261") |
| |
| | resip::defineMultiHeader (ProxyAuthorization, "Proxy-Authorization", Auth, "RFC 3261") |
| |
| | resip::defineMultiHeader (WWWAuthenticate, "Www-Authenticate", Auth, "RFC 3261") |
| |
| | resip::defineHeader (CSeq, "CSeq", CSeqCategory, "RFC 3261") |
| |
| | resip::defineHeader (Date, "Date", DateCategory, "RFC 3261") |
| |
| | resip::defineMultiHeader (Warning, "Warning", WarningCategory, "RFC 3261") |
| |
| | resip::defineMultiHeader (RESIP_DO_NOT_USE, "If you see this things are seriously awry", StringCategory, "NA") |
| |
| | resip::defineMultiHeader (Via, "Via", Via, "RFC 3261") |
| |
| | resip::defineHeader (RAck, "RAck", RAckCategory, "RFC 3262") |
| |
| | resip::defineMultiHeader (PVisitedNetworkID, "P-Visited-Network-ID", TokenOrQuotedStringCategory, "RFC 3455") |
| |
| | resip::defineMultiHeader (UserToUser, "User-to-User", TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17") |
| |
| | resip::defineMultiHeader (Identity, "Identity", IdentityCategory, "RFC 8224") |
| |