1#if !defined(RESIP_PARAMETERTYPES_HXX)
2#define RESIP_PARAMETERTYPES_HXX
19#define defineParam(_enum, _name, _type, _headertype, _RFC_ref_ignored) \
20 class _enum##_Param : public Param<_headertype> \
24 typedef _type::Type DType; \
25 virtual ParameterTypes::Type getTypeNum() const; \
26 virtual const char* name() const { return _name; } \
29 extern _enum##_Param p_##_enum
31#define defineParam2(_enum, _name, _type, _headertype, _headertype2, _RFC_ref_ignored) \
32 class _enum##_Param : public Param<_headertype>, public Param<_headertype2> \
36 typedef _type::Type DType; \
37 virtual ParameterTypes::Type getTypeNum() const; \
38 virtual const char* name() const { return _name; } \
41 extern _enum##_Param p_##_enum
46#define defineParam3(_enum, _name, _type, _headertype, _headertype2, _headertype3, _RFC_ref_ignored) \
47 class _enum##_Param : public Param<_headertype>, public Param<_headertype2>, public Param<_headertype3> \
51 typedef _type::Type DType; \
52 virtual ParameterTypes::Type getTypeNum() const; \
53 virtual const char* name() const { return _name; } \
56 extern _enum##_Param p_##_enum
65 virtual const char*
name()
const = 0;
#define defineParam(_enum, _name, _type, _RFC_ref_ignored)
#define defineParam2(_enum, _name, _type, _headertype, _headertype2, _RFC_ref_ignored)
#define defineParam3(_enum, _name, _type, _headertype, _headertype2, _headertype3, _RFC_ref_ignored)
Represents the "credentials" and "challenge" elements in the SIP grammar.
Represents the "via-branch" parameter of the RFC 3261 grammar.
Represents a CSeq header field value (this doesn't have an official name in the RFC 3261 grammar).
Represents the "callid" element in the SIP grammar.
Generically represents miscellaneous parameter data.
Represents the "SIP-date" element in the RFC 3261 grammar.
Represents various parameters that are indicated to be in effect merely by being present,...
Represents the header field value for an Expires-type header.
Represents the "absoluteURI" element in the RFC 3261 grammar.
Represents an Identity header from RFC8824.
Represents a numeric-with-comment header field value.
Represents the "media-type" element in the RFC 3261 grammar.
Represents the "name-addr" and the "addr-spec" elements in the RFC 3261 grammar.
virtual ParameterTypes::Type getTypeNum() const =0
virtual const char * name() const =0
Represents the "token" element in the RFC 3261 grammar.
Represents the "q" parameter value of the RFC 3261 grammar.
Generically represents miscellaneous parameter data that is encoded using double quotes.
Represents the RAck header field value defined in the RFC 3262 grammar.
Represents the "via-received" element in the RFC 3261 grammar.
Represents the "Request-Line" element in the RFC 3261 grammar.
Represents the "response-port" element of the SIP grammar (as extended in RFC 3581).
Represents the "Status-Line" element in the RFC 3261 grammar.
Represents the "header-value" element in the RFC 3261 grammar (ie, an unknown header field value).
Generically represents a token whose value can be wrapped and encoded using double quotes.
Represents the "token" element in the RFC 3261 grammar.
Represents a numeric-with-comment header field value.
Generically represents unsigned 32-bit integer values conveyed by SIP parameters.
Represents a URI enclosed in angle brackets, used in Identity headers for RFC8224.
Represents the "SIP-URI" and "SIPS-URI" elements in the RFC 3261 grammar.
Represents the "via-parm" element in the RFC 3261 grammar.
Represents the "warning-value" element in the RFC 3261 grammar.
dcm! – add UnusedChecking(_enum) below;