reSIProcate
SIP stack, Dialog Usage Manager and related libraries
Loading...
Searching...
No Matches
ParameterTypes.hxx File Reference

Go to the source code of this file.

Classes

class  resip::ParamBase
 
class  resip::Param< T >
 

Namespaces

namespace  resip
 dcm! – add UnusedChecking(_enum) below;
 

Macros

#define defineParam(_enum, _name, _type, _headertype, _RFC_ref_ignored)
 
#define defineParam2(_enum, _name, _type, _headertype, _headertype2, _RFC_ref_ignored)
 
#define defineParam3(_enum, _name, _type, _headertype, _headertype2, _headertype3, _RFC_ref_ignored)
 

Functions

 resip::defineParam (data, "data", ExistsParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (control, "control", ExistsParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (mobility, "mobility", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (description, "description", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (events, "events", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (priority, "priority", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (methods, "methods", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (schemes, "schemes", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (application, "application", ExistsParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (video, "video", ExistsParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (language, "language", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (type, "type", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (isFocus, "isfocus", ExistsParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (actor, "actor", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam2 (text, "text", ExistsOrDataParameter, NameAddr, Token, "RFC 3326/3840")
 
 resip::defineParam (cause, "cause", UInt32Parameter, Token, "RFC3326")
 
 resip::defineParam (extensions, "extensions", QuotedDataParameter, NameAddr, "RFC 3840")
 
 resip::defineParam (Instance, "+sip.instance", QuotedDataParameter, NameAddr, "RFC 5626")
 
 resip::defineParam (regid, "reg-id", UInt32Parameter, NameAddr, "RFC 5626")
 
 resip::defineParam (ob,"ob", ExistsParameter, Uri, "RFC 5626")
 
 resip::defineParam (pubGruu, "pub-gruu", QuotedDataParameter, NameAddr, "RFC 5627")
 
 resip::defineParam (tempGruu, "temp-gruu", QuotedDataParameter, NameAddr, "RFC 5627")
 
 resip::defineParam (gr, "gr", ExistsOrDataParameter, Uri, "RFC 5627")
 
 resip::defineParam (accessType, "access-type", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (algorithm, "algorithm", DataParameter, Auth, "RFC 2617")
 
 resip::defineParam (boundary, "boundary", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (branch, "branch", BranchParameter, Via, "RFC 3261")
 
 resip::defineParam (charset, "charset", DataParameter, Mime, "RFC 2045")
 
 resip::defineParam (cnonce, "cnonce", QuotedDataParameter, Auth, "RFC 2617")
 
 resip::defineParam2 (comp, "comp", DataParameter, Uri, Via, "RFC 3486")
 
 resip::defineParam (dAlg, "d-alg", DataParameter, Token, "RFC 3329")
 
 resip::defineParam (dQop, "d-qop", DataParameter, Token, "RFC 3329")
 
 resip::defineParam (dVer, "d-ver", QuotedDataParameter, Token, "RFC 3329")
 
 resip::defineParam (directory, "directory", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (domain, "domain", QuotedDataParameter, Auth, "RFC 3261")
 
 resip::defineParam2 (duration, "duration", UInt32Parameter, Uri, UInt32Category, "RFC 4240")
 
 resip::defineParam (expiration, "expiration", QuotedDataParameter, Mime, "RFC 2046")
 
 resip::defineParam2 (expires, "expires", UInt32Parameter, NameAddr, Token, "RFC 3261")
 
 resip::defineParam (filename, "filename", DataParameter, Token, "RFC 2183")
 
 resip::defineParam2 (fromTag, "from-tag", DataParameter, Token, CallID, "RFC 4235")
 
 resip::defineParam (handling, "handling", DataParameter, Token, "RFC 3261")
 
 resip::defineParam (id, "id", DataParameter, Token, "RFC 3265")
 
 resip::defineParam (lr, "lr", ExistsParameter, Uri, "RFC 3261")
 
 resip::defineParam2 (maddr, "maddr", DataParameter, Uri, Via, "RFC 3261")
 
 resip::defineParam (method, "method", DataParameter, Uri, "RFC 3261")
 
 resip::defineParam (micalg, "micalg", DataParameter, Mime, "RFC 1847")
 
 resip::defineParam (mode, "mode", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (name, "name", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (nc, "nc", DataParameter, Auth, "RFC 2617")
 
 resip::defineParam (nonce, "nonce", QuotedDataParameter, Auth, "RFC 2617")
 
 resip::defineParam (opaque, "opaque", QuotedDataParameter, Auth, "RFC 2617")
 
 resip::defineParam (permission, "permission", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (protocol, "protocol", QuotedDataParameter, Mime, "RFC 1847")
 
 resip::defineParam2 (purpose, "purpose", DataParameter, GenericUri, TokenOrQuotedStringCategory, "RFC 3261, draft-ietf-cuss-sip-uui-17")
 
 resip::defineParam3 (q, "q", QValueParameter, NameAddr, Token, Mime, "RFC 3261")
 
 resip::defineParam (realm, "realm", QuotedDataParameter, Auth, "RFC 2617")
 
 resip::defineParam2 (reason, "reason", DataParameter, Token, NameAddr, "RFC 3265, 5806")
 
 resip::defineParam (received, "received", ReceivedParameter, Via, "RFC 3261")
 
 resip::defineParam (require, "require", ExistsParameter, Token, "RFC 5373")
 
 resip::defineParam (response, "response", QuotedDataParameter, Auth, "RFC 3261")
 
 resip::defineParam (retryAfter, "retry-after", UInt32Parameter, Token, "RFC 3265")
 
 resip::defineParam (rinstance, "rinstance", DataParameter, Uri, "proprietary (resip)")
 
 resip::defineParam (rport, "rport", RportParameter, Via, "RFC 3581")
 
 resip::defineParam (server, "server", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (site, "site", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (size, "size", DataParameter, Mime, "RFC 2046")
 
 resip::defineParam (smimeType, "smime-type", DataParameter, Mime, "RFC 2633")
 
 resip::defineParam (stale, "stale", DataParameter, Auth, "RFC 2617")
 
 resip::defineParam (tag, "tag", DataParameter, NameAddr, "RFC 3261")
 
 resip::defineParam2 (toTag, "to-tag", DataParameter, Token, CallID, "RFC 4235")
 
 resip::defineParam (transport, "transport", DataParameter, Uri, "RFC 3261")
 
 resip::defineParam2 (ttl, "ttl", UInt32Parameter, Uri, Via, "RFC 3261")
 
 resip::defineParam (uri, "uri", QuotedDataParameter, Auth, "RFC 3261")
 
 resip::defineParam (user, "user", DataParameter, Uri, "RFC 3261, 4967")
 
 resip::defineParam2 (extension, "ext", DataParameter, Uri, Token, "RFC 3966")
 
 resip::defineParam (username, "username", QuotedDataParameter, Auth, "RFC 3261")
 
 resip::defineParam (earlyOnly, "early-only", ExistsParameter, CallID, "RFC 3891")
 
 resip::defineParam (refresher, "refresher", DataParameter, ExpiresCategory, "RFC 4028")
 
 resip::defineParam (profileType, "profile-type", DataParameter, Token, "RFC 6080")
 
 resip::defineParam (vendor, "vendor", QuotedDataParameter, Token, "RFC 6080")
 
 resip::defineParam (model, "model", QuotedDataParameter, Token, "RFC 6080")
 
 resip::defineParam (version, "version", QuotedDataParameter, Token, "RFC 6080")
 
 resip::defineParam (effectiveBy, "effective-by", UInt32Parameter, Token, "RFC 6080")
 
 resip::defineParam (document, "document", DataParameter, Token, "draft-ietf-sipping-config-framework-07 (removed in 08)")
 
 resip::defineParam (appId, "app-id", DataParameter, Token, "draft-ietf-sipping-config-framework-05 (renamed to auid in 06, which was then removed in 08)")
 
 resip::defineParam (networkUser, "network-user", DataParameter, Token, "draft-ietf-sipping-config-framework-11 (removed in 12)")
 
 resip::defineParam (url, "url", QuotedDataParameter, Mime, "RFC 4483")
 
 resip::defineParam2 (sigcompId, "sigcomp-id", QuotedDataParameter, Uri, Via, "RFC 5049")
 
 resip::defineParam (qop,"qop", DataParameter, Auth, "RFC 3261")
 
 resip::defineParam (index, "index", DataParameter, NameAddr, "RFC 4244")
 
 resip::defineParam (rc, "rc", DataParameter, NameAddr, "RFC 4244-bis")
 
 resip::defineParam (mp, "mp", DataParameter, NameAddr, "RFC 4244-bis")
 
 resip::defineParam (np, "np", DataParameter, NameAddr, "RFC 4244-bis")
 
 resip::defineParam (utranCellId3gpp, "utran-cell-id-3gpp", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (cgi3gpp, "cgi-3gpp", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (ccf, "ccf", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (ecf, "ecf", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (icidValue, "icid-value", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (icidGeneratedAt, "icid-generated-at", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (origIoi, "orig-ioi", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (termIoi, "term-ioi", DataParameter, Token, "RFC 3455")
 
 resip::defineParam (content, "content", DataParameter, TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17")
 
 resip::defineParam (encoding, "encoding", DataParameter, TokenOrQuotedStringCategory, "draft-ietf-cuss-sip-uui-17")
 
 resip::defineParam (info, "info", UriParameter, IdentityCategory, "RFC 8224")
 
 resip::defineParam (alg, "alg", DataParameter, GenericUri, "RFC 8224")
 
 resip::defineParam (ppt, "ppt", DataParameter, GenericUri, "RFC 8224")
 
 resip::defineParam (counter, "counter", UInt32Parameter, NameAddr, "RFC 5806")
 
 resip::defineParam (limit, "limit", UInt32Parameter, NameAddr, "RFC 5806")
 
 resip::defineParam (privacy, "privacy", DataParameter, NameAddr, "RFC 5806")
 
 resip::defineParam (screen, "screen", DataParameter, NameAddr, "RFC 5806")
 
 resip::defineParam (qopOptions,"qop", DataParameter, Auth, "RFC 3261")
 
 resip::defineParam (addTransport, "addTransport", ExistsParameter, Uri, "RESIP INTERNAL")
 
 resip::defineParam (wsSrcIp, "ws-src-ip", DataParameter, Uri, "RESIP INTERNAL (WebSocket)")
 
 resip::defineParam (wsSrcPort, "ws-src-port", UInt32Parameter, Uri, "RESIP INTERNAL (WebSocket)")
 

Macro Definition Documentation

◆ defineParam

#define defineParam (   _enum,
  _name,
  _type,
  _headertype,
  _RFC_ref_ignored 
)
Value:
class _enum##_Param : public Param<_headertype> \
{ \
public: \
typedef _type Type; \
typedef _type::Type DType; \
virtual ParameterTypes::Type getTypeNum() const; \
virtual const char* name() const { return _name; } \
_enum##_Param(); \
}; \
extern _enum##_Param p_##_enum
void list()
Definition userAdmin.cxx:66

Definition at line 19 of file ParameterTypes.hxx.

◆ defineParam2

#define defineParam2 (   _enum,
  _name,
  _type,
  _headertype,
  _headertype2,
  _RFC_ref_ignored 
)
Value:
class _enum##_Param : public Param<_headertype>, public Param<_headertype2> \
{ \
public: \
typedef _type Type; \
typedef _type::Type DType; \
virtual ParameterTypes::Type getTypeNum() const; \
virtual const char* name() const { return _name; } \
_enum##_Param(); \
}; \
extern _enum##_Param p_##_enum

Definition at line 31 of file ParameterTypes.hxx.

◆ defineParam3

#define defineParam3 (   _enum,
  _name,
  _type,
  _headertype,
  _headertype2,
  _headertype3,
  _RFC_ref_ignored 
)
Value:
class _enum##_Param : public Param<_headertype>, public Param<_headertype2>, public Param<_headertype3> \
{ \
public: \
typedef _type Type; \
typedef _type::Type DType; \
virtual ParameterTypes::Type getTypeNum() const; \
virtual const char* name() const { return _name; } \
_enum##_Param(); \
}; \
extern _enum##_Param p_##_enum

Definition at line 46 of file ParameterTypes.hxx.